TN Document Type EDIINT shows "ERROR: The Java class for this document type was not "

We have installed webmethods 6.5 with EDI Packages(WmEDIINT,WmEDIforTN,WmEDI) on Solaris machine
When we open the TN console and navigate to the Documents Types screen
For TN DocumentType EDIINT following error is displayed in the Description
“ERROR: The Java class for this document type was not found”

When we send a EDI document to EDIINT/receive service the document type is not recognized
The edint.jar,edintdoc.jar files are present in /packages/WmTN/code/jars
as well as the classes
EDIINTEnvelopeConstants.class,EDIINTEnvelopeDocType.class,EDIINTMDNEnvelopeDocType.class are present in
/packages/WmEDIINT/code/classes/wm/EDIINT/doc

I have also gone through the serverlog . When a EDI document is submitted using EDIINT protocol following msgs is displayed in log
In the log you will see that wm.EDIINT.doc.EDIINTMDNEnvelopeDocType is displayed but not the wm.EDIINT.doc.EDIINTEnvelopeDocType. Thoough both these classes are in same jar

2006-02-24 09:00:05 EST [ISU.0000.9999V2] Initializing type cache, ID={0} [TRNS
ERV.000016.000123]
2006-02-24 09:00:05 EST [ISU.0000.9999V2] Selecting all BizDocType definitions
2006-02-24 13:30:36 EST [ISU.0000.9999V2] BizDocTypeReg: pipeline will not be a
wm.b2b.editn.EDIEnvelopeDocType [TRNSERV.000019.000012]
2006-02-24 13:30:36 EST [ISU.0000.9999V2] BizDocTypeReg: pipeline will not be a
wm.EDIINT.doc.EDIINTMDNEnvelopeDocType [TRNSERV.000019.000012]
2006-02-24 13:30:36 EST [ISU.0000.9999V2] BizDocTypeReg: input pipeline is UNKNO
WN [TRNSERV.000019.000003]

How to add classes in classpath and/or which classes are missing and where should I add them to solve the problem Or which configuration file should be changed

thanks in advance
Help appreciated

Have you tried to reload all the EDI related packages or restarting IS? So IS will reinitialize those missing EDI classes in the env for any new installations.I know this is a standard debug process and you might have done this.

If problem still persists,this could be a bug in the EDIModule65 (in EDIINT reg),please let this forum know if you find any solution/fix/patch by yourself or from tech support.

HTH,
RMG

koolhulk: I removed the duplicate post from the IS forum and kept this one since it had more descriptive info. I also moved it to this EDI forum where it is most applicable.

Hi RMG and Forum Members

I have resolved the issue

Steps taken to resolve the issue
1)Deleted the EDIINT doctype entry from database. I used wm.tndoctype:add service.

2)Uninstalled EDI, EDIINT packages

3)Reinstalled the packages

and it solved the issue

Thanks

Sorry.
One correction the service used to delete the Doctype was wm.tn.doctype:delete

Thanks for updating resolution,it will help everyone.

What is the reason behind it?when you are trying to fresh install EDI65 module?Is this the same problem faced by others when installing EDIINT?

HTH,
RMG