Timestamp on SPoD modified mainframe objects

I recently got SPoD debugger working with our system. However, when I save/stow an object on the mainframe the timestamp is the Germany timezone. That is, U.S. Pacific coast time +8.

I have searched the help and haven’t been able to find how to change this timestamp.


I assume the NDV server is running with a different time differential (TD) setting than your online Natural,
try connecting to NDV with an override parameter of TD=AUTO.


That did it, Wolfgang, thank you!

If this trick worked I believe the logical time zone of this mainframe is “U.S. Pacific coast time”.

And if you got a “green screen” connection to this mainframe you would also have this time stamp issue.

If not, the “green screen” session is configured with this TD=AUTO parameter (e.g. in NATPARM). Perhaps you should contact you administrator and ask him/her why this is not configured for the NDV server.

Yes, I am in California.

Yes, we do have the green screen connection to the mainframe, via browser/Passport sessions.

I tried using the Configuration Utility to set the NATPARM/Regional Settings/Time Differential to -8:0 but that did not have any effect, so I went back to TD=AUTO in the Session Parameters.

Is the TD=AUTO parameter available on the NDV server as well?

Yes, the NDV server uses the very same Natural parameters as “green screen” or batch Natural.

After all it just starts a backend Natural session for you on the server :wink:

This is for local sessions when you execute programs on your pc. It has no influence for your SPoD session that execute the program on the NDV server. It is the TD value configured for Natural on the NDV server which takes effect.


Thanks for the clarification, Mogens.

My administrator has added the TD parameter to the NDV server and has made some other changes to help stabilize SPoD.