Task with delivery of Primary E-mail fails.

I’m trying to send a transaction through Trading Networks via Primary Email to a partner. The delivery task fails with the message:
Delivery service for m1iq0t0075s7ld2e0000009q failed with a status of fail and status message of com.wm.app.b2b.server.ServiceException: javax.mail.MessagingException: Could not connect to SMTP host: localhost, port: 25; nested exception is: java.net.ConnectException: Connection refused: connect

I am using webMethods 8.2.

I do not have an SMTP server configured on the webMethods server.

In IS Administrator → Settings → Resources, the SMTP server setting is configured to our internal SMTP server. When the task above failed, the mailbox configured under “Internal Email” and “Server Email” received messages with the same error as in the task.

In My webMethods, Administration → My webMethods → E-Mail Servers, the same SMTP server and port are configured as in IS Administrator. The “Send Test Email” button on that page sends me an email successfully.

I can’t find any other place to specify an SMTP server. I’ve searched through the TN Administrator’s Guide, but it only mentions the IS Administrator → Settings → Resources setup, which I’ve described above.

Can someone tell me what setup I’m missing?

Problem solved – I restarted both webMethods IS and My webMethods services and now the email works.