Tamino databases of 4.4 version do not start


I had Tamino DB 4.4.1.(6) installed and it worked perfectly. I have just updated it to Tamino 8 and the databases created in the 4.4 version do not start. I am allowed to create new databases in 4.4 but they have the same problem.
With databases in Tamino 8 version I do not have problems, but I need some old databases to start.

The messages are the following:

INODSA2278: Tamino server on Windows
INODSS1712: Starting database server
INODSR1687: Reading parameters

INODSI2314: Licensed for Software AG Spain ****** with ID ***, license expires on +++++++
INOXHI8151: Communication method: XTS and TCP/IP
INOXHR8245: Initializing XML processing
INOXHI8265: Default tokenizer ‘white space-separated’
INODSA1000: Starting autorepair after abnormal termination
INODSS1711: Recovering from abnormal termination
INODSR1682: Analyzing journal information
INODSR1684: Reconstructing consistent index structures. Processing journal block 3.
INODSR1683: Re-applying changes. Processing journal block 3.
INODSR1685: Resetting unfinished transactions. Processing journal block 3.
INODSI1631: Autorepair completed without errors
INODSR1686: Recovered from abnormal termination
INOXHR8246: Starting XML threads
INODSE2031: Internal error occurred: DSIF DSIF_SET_NUMERIC_PARAMETER_VALUE [xthsrv.cpp - 1845] invalid parameter iParValue
INODSF1261: Assertion failed: rc == DSIF_RC_SUCCESS
INODSF1454: Internal error occurred: location XML-WRK-0003 xthsrv.cpp 1846. Server stopped.
INODSA1001: Start writing crash dump of database, writing to file C:\Documents and Settings\All Users\Application Data\Software AG\Tamino\Tamino.AAC.13-04-12.1M0
INODSI1635: Crash dump of database finished
Start writing SAGSMP dump, writing to file C:\Documents and Settings\All Users\Application Data\Software AG\Tamino/SAGSMP.AAC.13-04-12.0M0
Dump of SAGSMP finished
INOXHA8259: Start writing XML dump of database, writing to file C:\Documents and Settings\All Users\Application Data\Software AG\Tamino\Tamino.AAC.13-04-12.xml
INOXHI8260: XML crash dump of database finished
INODSF1436: Terminated with errors

Kind Regards.

If I change the “communication method” of those databases from “XTS and TCP/IP” to “TCP/IP”, I am able to start them.

Databases created in Tamino 8 work perfectly having the “communication mehod” set to the default, that is “XTS and TCP/IP”.

Is there a way to make them work all correctly with the default setting?


I discovered another workaround to be able to start the Tamino 4.4 databases which is asigning to them manually a port in the “XML XTS port” property. If the configured value is 0, I am unable to start them with the “XTS and TCP/IP” communication method. If that configured value is a valid value, then I can start them with “XTS and TCP/IP” communication.

Anyway I think of both “solutions” I gave as workarounds. The original problem I believe it is not solved.


This problem is fixed in 4.4.1 SP8.