serious problems upgrading from tamino to 4.2.1


I have tried to upgrade from Tamino version to 4.2.1 on Windows 2000 server, but experienced serious problems.

I installed version 4.2.1 ? completed, and it succeeded. I then rebooted the server as it said I should. When I logged on I got the following message:

The procedure entry point OVO_V25 could not be located in the dynamic link library sagovo2.dll.

I could start Tamino Manager. But when I tried to select the old database (version 4.1.4) I got the message again:
The procedure entry point OVO_V25 could not be located in the dynamic link library sagovo2.dll.

I also tried to start the old database using ?argbatch start?, but the same result.

I was, as far as I remember, able to start the newly installed welcome database.

I then uninstalled version 4.2.1 and rebooted the server. Tried again and got the same result. The Tamino Manager (System Management Hub), was however, in the new layout, so properly it didn?t uninstall all of the newly installed Tamino.

I then tried to install 4.1.4 again and selected the repair mode. That didn?t help either.

I then uninstall all Tamino programs and installed version 4.1.4 again. Then I was able to start the old database again.

I the installed version 4.2.1, and was asked to install path level 4. After installing that I was able to install 4.2.1, this time not selcting complete, but custom). During the install I get the following error:

The installation program detected that the range of ports you have selected conflicts with a port already in use on your PC. Use a different port range to avoid this problem.

But changed the port range to include these ports didn’t help. I then selected higher port numbers, and that helped. Would be nice if the suggested port number was correct.

After install everything worked.

My questions are now before I upgrade on our production server:
- what do I do to avoid this error again (do I need to uninstall something first (e.g. non-xml indexer or wedav)? Or nor select a complete installation or?)
- if the error happens again, what?s the suggested solution?

Regards from Ole

InterResearch A/S - Vestergade 9 - DK-1456 Copenhagen K
Phone: +45 70 27 28 72 - Mobile: +45 20 10 21 74 - Fax: 70 27 28 79
E-mail: - Homepage:

Hi Ole,

Tamino R&D has not seen this problem before. It seems that in the installation of Software AG Base Technology, something went wrong (Tamino 4.2.1 installs a new version of Base Technology). Installing this component manually could solve the problem - the setup is on the Tamino CD