SSL error when enabling webMethods Adapter for JDBC

What are trying to achieve? Please describe in detail.

Trying to enable webMethods Adapter for JDBC through Integration Server Administration UI (by navigating to Adapters > webMethods Adapter for JDBC > Connections and clicking enable).

However, when I attempt to enable, I get the error shown below. I’ve also tried setting up a new connection (non SSL), and still get the same error as shown below.

Note: When testing connection to DB using DBeaver and no SSL, I am able to connect successfully.

Do you get any error messages? Please provide a full error message screenshot and log file.

Error encountered

[ART.118.5042] Adapter Runtime (Connection): Unable to enable connection resource commonSupport.adapters:acmeAdapter. [ART.118.5063] Adapter Runtime (Connection): Unable to start connection commonSupport.adapters:acmeAdapter: after 1 attempt(s). [ART.118.5036] Adapter Runtime (Connection): Unable to configure connection manager. [ADA.1.204] Cannot connect to the database with DataSource class “com.microsoft.sqlserver.jdbc.SQLServerDataSource”. The driver could not establish a secure connection to SQL Server by using Secure Sockets Layer (SSL) encryption. Error: “PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target”. ClientConnectionId:4f0632b4-c766-455e-ae5b-56955e9e7007

What product/components do you use and which version/fix level?

Software:
Integration Server:

Product Integration Server
Version 10.11.0.0
Updates IS_10.11_Core_Fix4
IS_10.11_WmCloud_Fix2
Trading Networks Server 10.11 Fix 1
Build number 724
SSL The JCE Unlimited Strength Jurisdiction Policy File was found

Server Environment:

Java version 11.0.15 (55.0)
Java VM name OpenJDK 64-Bit Server VM
Java build info 11.0.15+10-LTS, mixed mode
Java vendor Azul Systems, Inc.
Java home C:\SoftwareAG\jvm\jvm
Java Entrust Toolkit version Entrust Authority™ Security Toolkit for the Java(R) Platform version 8.0 Patch 192190 FIPS
Data Direct version 6.0
Server process ID 17004
SQL Server Management Studio 15.0.18420.0
SQL Server Management Objects (SMO) 16.100.47021.0+7eef34a564af48c5b0cf0d617a65fd77f06c3eb1
Microsoft Analysis Services Client Tools 15.0.19750.0
Microsoft Data Access Components (MDAC) 10.0.19041.1
Microsoft MSXML 3.0 6.0
Microsoft .NET Framework 4.0.30319.42000
Operating System 10.0.19044

Software AG Designer 10.11

DBeaver 22.1.0

Are you using a free trial or a product with a customer license?

Licensed product

I faced this when I tried to communicate to a target ADFS server and solved it by importing the target’s CA certificate into the IS Truststore.
However, I’m unsure if this will apply for JDBC (I don’t see why not, as it’s TLS), but give it a try.

KM

This is not the issue we are facing. SSL is not in picture for client or a server because it’s happening on a local dev machine. Everything is installed on local.

Hi,

in this case you should check your DB config as the DB presents a certificate which the IS cannot validate due to missing intermediate and/or root certificates.

Can you share your JDBC connection config so we can check it?

Regards,
Holger


Here is the JDBC configuration as requested.

Use encrypt=true;trustServerCertificate=true in the other properties. Latest Microsoft JDBC Driver enforces the encryption by default.

1 Like

This works, I can now enable the adapter. Thanks.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.