SFTP, OpenSSH with Password Authentication, not RSA Key

We installed Cygwin and the OpenSSH package, and have successfully used it with a trading partner, using the RSA key authentication.

Now, we have a trading partner that has a SFTP server for us to pick up files from, but we have found out that they cannot support RSA key authentication. They have told that they can only support password authentication.

Well, we have tried many things and to no avail.

What are we not doing? We haven’t been able to find any documentation to deal with this specifically. Any documentation we have seen pertains to user-interaction with the console to type in the password, or, that we should use RSA key (which isn’t an option for this round).

What part of the setup are we missing? What parameter or configuration are we missing? Where do we specify the password?

Thanks for any help.
Wayne

Wayne,
To use sftp you must have some type of SSH available. Did you exchange any authentication key?

-Jim

Thanks for the reply.

Yes, we have Openssh setup and functional. We use it for one trading partner which we have exchanged authentication keys.

But the new trading partner can only use password authentication, NOT authentication with a key.

Wayne

I am having a similar implementation and what I did is I downloaded some ssh java package from the net and make some java code customization to authenticate using password.
And I was able to execute the Sftp successfully from linux using same JVM; however when I call it from Java service it made the IS Server(6.5) shutdown abnormally then when I put the exception handling piece I saw that it throws this exception

invalid protocol(kex): 21

Probably its a setup issue since its working fine from linux.

Wayne, Did you manage to get a resolution ?

Any direction where to look is appreciated

Thanks,

  • Mohammad.

Would you please share your resolution about it? We have a new partner request to use the Password authentication too. Thanks a lot.

you may try:
www.jcraft.com/jsch
it’s pure java, you should have option of use user/pass auth

We are on wm8.0 and the wasftp package supports sftp with a username and password instead of keys.

I don’t think it supports with out any keys unless the target FTP server puts less restrictions/ignore keys/cert validation from your IP.

HTH,
RMG

Chris,Where did you get this package from Empower site?

Also does it support on 712/713?

Please advise your inputs:

TIA,
RMG

I’m unsure what you mean by 712/713.
I’m also unsure where the package came from. I have not been able to find out who the first user was at our site to find out where it came from. I have a clean install of WM8.0 on my desktop and the package is not there so that tells me this was an add on.
The package contains mostly java services(I’m not a java guy). The login service appears to connect via a jscsh session.

I was referring to IS 712/713.

So you have the package installed by some one else from your team as WasFTP package services you been using on 8.0 If I understand you correctly?

I assume your team build that custom package via JCraft Java methods for SFTP?

Hi cbordeaux,
Could I ask you to email me the zipped pacakge wasftp? We need to use SFTP and I am going nuts at this point of time.

I will shortly send you a private email with my details

Thanks heaps mate,

I talked to the guy who downloaded the package. He is pretty sure he downloaded it from either here or the empower site. I have searched both sites pretty well and cannot find the package.

I tried to reply to your PM but it said your inbox was full. I also tried to email your hotmail account but received an error that the address could not be found.

Until I figure out where it came from I can’t in good conscience send it out since I did not write it myself. I would think that to be similar to pirated software. If I can figure out where we got it from and can find a link for it I’ll certainly send it out.

I opened a ticket with SoftwareAG asking if they have any issue with me sharing the package. If they don’t have an issue I expect it will be ok to share it here.

Sorry…I have freed up my PM…

Great…thanks Chris for trying more:

Software AG said I could send out the package. They said it used to be available for download. They also said that SFTP should be part of WM 9.0.

I tried to upload the package but it is about 230k zipped and the site will only allow 97k. Does anyone know of a way around that or have special privileges? I would rather post it somewhere public than email it to everyone who wants a copy.

some what good news and thanks for the update…but they support it from Active Transfer product for now.

Can you upload it to google drive and share?

great idea, here is the link.
https://docs.google.com/file/d/0BzEc0nAyqInlX3l0NEZYVUhJeVk/edit?usp=sharing
you should be able to click the link and then go to File/download and download it.

This “pirated software” and “consciousness” statements are out of context. How could YOU use it when you don’t know its source? If the lack of source identity makes it (potentially) pirated then it should be for you as well as others. The truth is there is NOTHING about that package on the net except on this forum, so it is highly unlikely to be copyrighted work, and it is highly likely to be the work of some enthusiast who never cared if it gets copied or passed on and you are unlikely to ever find who they were. That is enough evidence from ethical and legal perspectives to pass on knowledge to others in need, but I guess because you already have that package you can sit and talk about conciseness when it comes to helping others. Nevermind sir! We will find another way.