sftp login: setup userAlias

I am glad to see that sftp is now part of the wm.pub.client library. I started to setup a test but was stumpted with the login service; “userAlias” field. I assume this is a reference to the host, port, username, password but I could not figure out how to create the userAlias with these references.

You might have to setup alias from the IS Admin sftp port configuration side from 9.0?


Hi Leo ,

In order to use SFTP related service which is available from 9.0 onwards , you have to do some configuration from your IS admin page.Follow the following procedures :-

  1. Go to Setting —> SFTP tab from IS admin screen and then create a server alias for the corresponding SFTP server to which you want to connect.
  2. After successful creation of the server alias you have to create the user alias for the corresponding server alias you just created.

Then use the same user alias and pass it to the service “pub.client.sftp:login”.

Hope this solves your problem.

Thanks for the tips. This appears to solve my problem.

Thanks for chime in more on this topic.

I am doing a POC on SFTP in wM 9.6 evironment. IS is installed on my system (OS : windows 7). I have tried setting up SFTP userAlias and I am trying to use Authentication type as Public Key. For Public Key authentication one has to provide private key location and its passphrase. I am generating keypair using putty key generator and providing private key location in UserAlias setup but when I test the alias I am always getting the error “Invalid Private key”.

I have no idea how to debug the error, can any one help me ?

Did you make sure the private key generation is good/valid? as it complaining the same.

Please check it may be use some other tool like procele etc…



Thanks for your reply. I have tried portecle but it generates keystores and doesnt generate individual key pairs which would be needed to setup SFTP User alias in IS.

I guess the issue is with ‘Private Key Location’ field in User alias properties need to have better understanding what values should be provided for it. I havent found much description about the field in SAG docs.

The private key which I am using has ‘.ppk’ format which was generated using putty key generator and I guess IS is not recognizing the format. I am trying to explore more options. But if any one has a better idea how to do setup please do pitch in.

I have also attached the screen shots of the error.

SFTP Issue in wM 9.6.docx (86.3 KB)

Did u get a resolution for this, I’m facing similar issue.


the following thread might also be helpful: