Set ConversationID via wmtndocffrouteFlatFile

Hi all.

Quick question. I have created a Gateway service to submit an internal flat file document to Trading Networks. It all works fine, except for the ConversationID. I’d like to set one using TN_parms, which is part of the input signature for routeFlatFile. The documentation (Building_Your_Trading_Network.pdf - page 381 from the version 6.0.1 guide) says that one of the optional TN_parms “hints” is a ConversationID. But when I set it before invoking routeFlatFile, nothing seems to happen. The bizdoc is still submitted successfully, but my conversation id does not appear in the TN Console.

Any ideas?


I think you have to extract the conversation id. Go to your document type and go the extract section. Make sure you extract the conversation id as well.


For accomplishing this make sure in the TNDoctypes section select your documenttype and under Extract/SystemAttributes select the ConversationID (Required)checkbox,same like you have done extraction for Sender/ReceiverID’s.


Yep, that was it. Thanks guys. I didn’t realize that the only system attributes that TN extracted by default was the sender and receiver ids.

Now I do.