Service Orchestrator - Trouble starting Mail Portal

Hi All;

Trying to get the Mail Portal started in XSI 3.1;
I am using gmail as the mail server - it supports access via POP3; I tested it with the mozilla thunderbird mail client and it worked fine, I was able to retrieve all my emails from gmail.
I tried to use the same settings in the Mail Portal definition:

-----from SMH-----
Name: EmailTestPortal
Description: test portal
Sequence URL: file:/D:/Mediator/TEST/EmailPortalTest/sequences/default.xml
POP3 Host:
POP3 Port: 995
User ID: b2bnissan
Poll Interval ([S|M|H|D]: 1m
Worker Thread Count: 1
Autostart: false
Log Level: DEBUG
Status: Down
Number of Reconnect Attempts:
Reconnect Interval:

When I try to start the portal, I get this error:
“Unable to start the portal. Message : com.softwareag.xbridge.portals.PortalException: embedded exception: EOF on socket”

Several things I have noted:

There is supposed to be a property ‘xbd.mail.portal’ pointing to the mail portal config file; the documentation says that this property should be created automatically, but I do not see it when I run an enumeration TO_XML for example. I searched for the config file in the web deployment, could not find it.

The last two Mail Portal parameters show always as empty, even though I set and reset them several times.

I tried changing the POP3 host to an non-existent address, and it gave me a different error:
“Unable to start the portal. Message : com.softwareag.xbridge.portals.PortalException: embedded exception: Connect failed; nested exception is: Connection reset”
This is the type of error I would expect if my URL (in this case POP3 host name) was wrong.

  • so I reckon that this is where the error is, though I have no trace or log to show.

I notice that in the thunderbird mail client configuration, you can choose to enable SSL - if you do not enable SSL, you get an error when trying to connect. Only with SSL enabled does the connection work. Could this be the problem with the mail portal?

best regards,

  • arp

Yup - seems to be the SSL setting, or something else specific to google POP handling.
With the internal Exchange Server it works like a charm.