SOAPGateway Axis Fault- requested URL could not be retrieved

Hi folks,

I am getting an Axis fault when I try to call a webservice via SOAPGateway. The fault is reported in the DefaultComponentFactory.xbd.log file and it contains the following html:

		<META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=iso-8859-1">
		<TITLE>ERROR: The requested URL could not be retrieved</TITLE>
		<STYLE type="text/css">
		<H2>The requested URL could not be retrieved</H2>
		<HR noshade size="1px">
		<P>While trying to retrieve the URL:<A HREF="/entirex/xmlrt">/entirex/xmlrt</A>
		<P>The following error was encountered:<UL><LI><STRONG>Invalid URL</STRONG></UL>
		<P>Some aspect of the requested URL is incorrect. Possible problems:
		<LI>Missing or incorrect access protocol (should be `http://'' or similar)
		<LI>Missing hostname
		<LI>Illegal double-escape in the URL-Path
		<LI>Illegal character in hostname; underscores are not allowed
		<P>Your cache administrator is <A HREF=""></A>. 
		<BR clear="all"><HR noshade size="1px">
		<ADDRESS>Generated Mon, 21 Nov 2005 16:01:19 GMT by (squid/2.5.STABLE12)</ADDRESS>

As you can see, it states that it cannot retrieve url /entirex/xmlrt

The following wsdl file extract shows the fully qualified url in the port element:

<service name="xbd-ws">
    <port name="XBD-WSPort" binding="tns:XBD-WSSoapBinding">
        <soap:address location="http://localhost:8080/entirex/xmlrt"/>

It looks as though the first part of the url (http://localhost:808) is being lost somewhere.

The wsdl file was generated in EntireX Workbench. If I enter full url http://localhost:8080/entirex/xmlrt in a browser, I see the default EntireX XML Servlet page as I would expect.

Does anybody have any ideas on what is wrong and how it can be fixed?

Thanks in advance,
David Sanders

Hi David,

The error appears to be coming from your proxy server. Is Mediator configured properly for the server? Is the server configured properly for the target URL?

Hope this helps.

Hi Mike,

Thanks for the advice. I got it working by adding localhost to the nonProxyHosts list in the JVM Options.