sequelink odbc datasource

Hello, I need help defining an ODBC datasource on the Sequelink server on Solaris.

I can use the sqlnkcau utility that comes with the ODBC client to define and test the datasource, but I get the following error.

SequeLink Server error 10004
[S1000]The requested ODBC datasource is not defined on the server system.
Tamino error -1454
[S1000][MERANT][Tamino server][Tamino]1454(E): client server interface send
Test failed: connection to ‘tamino’ failed.

As far as I can tell the sqlnkcau utility only comes with
the SQLink ODBC client , which gets installed to a separate directory and
holds its own datasource names.
The client installs to
/usr/sqlnk/4_51_00/bin (sqlnkcau and sqlnkcausilent)

but the server installs to
/usr/sqlnk/4_00_00/bin (sltam only)

It looks like to me like there is a sequelink server script:
/usr/sqlnk/instances/ and SLTamino.cfg
that points to a directory which is supposed to contain my odbc
configuration for the server:
But this directory is different than where the client sqlnkcau utility is
storing the datasources:

Any ideas?


Lee Murray
Vivare, Inc.

Hi Lee,

I have Tamino on Solaris working with Sequelink.
In the “sagenv” file there is call to
and this script sets the following environment variable:
I think the key for all this work is this environment variable ODBCINI.
So if you point it to your /usr/sqlnk/4_51_00/ini/sqlnkdsn.ini all works fine.


thanks for the help, but I am still having problems.

I tried your suggestion but it didn’t work.
Maybe you could clarify a few things for me about your configuration since you seem to have it working.
Are you running the same versions as I?
-tamino 3111
-sequelink server 4
-sequelink odbc client 451

I realize what you are saying that it is probably environment variables - it is just that there are so many separate scripts that set the env variables.

Here is what I understand about the chain of scripts/environments

inetd.conf runs the sequelink server script as root: (from /etc/inetd.conf)
(root has no variables set in /etc/profile)
isl4015 stream tcp nowait root /usr/sqlnk/instances/ runs and calls the sequelink server binary (sltam)
( I tried adding the call to /usr/SAG/ to this but it didn’t seem to help)

#. /usr/SAG/

export VERSION
export ISLVINI

exec /usr/sqlnk/4_00_00/bin/sltam -S SLTamino > /usr/sqlnk/SLTamino.log 2>&1


Here is where I am lost. apparently the sltam binary is looking at some variables to determine how to find the ODBC datasource entries, and I can’t tell how it would get back to the
/usr/SAG/v3111/sqlnk/ or /usr/SAG/ scripts, unless I tell inetd to run the script as the sag user or add these calls to the script.

Here is a summary of all the variables and scripts
that set them that I can find:
-/usr/sqlnk/instances/ and .cfg

And here is a list of all the odbc definitions I can find
-/usr/sqlnk/4_51_00/ini/.odbc.ini and other sqlnk*.ini

if you could help clear up I would appreciate it