SecurityException when install X-Tention

I write XTention with JDK1.4 and the class java.util.logging.Logger is used .
But it cann’t be installed,an error is reported:

INOSXE7114: Java error: java.lang.SecurityException: Prohibited package name: java.util.logging

I use tamino4.1.1

X-Tension creates, upon server start-up, an own SXSSecurityManager that restricts some alicious actions in its method checkPermission(). This SXSSecurityManager is derived from the system class SecurityManager, from which it inherits the default implementation for all other check-methods except checkPermission().

Thus, by creating the SecurityManager the policy file <java.home>\lib\security\java.policy,
where most permissions are specified, is activated. So please check this policy file if there is any restricition to the java.util.logging package.
Regards, Michael

I have added the “AllPermission” to the policy file,but it still not work.

but another issue:I cann’t add the “LoggingPermission”, the error message is:

Hi cowboy

The method checkPackageAccess(pkg) first checks if pkg starts with or equals any of the restricted packages given in“package.access”) and then checks the RuntimePermission(“accessClassInPackage.”+pkg). If the first check fails, the AllPermission does not help. So please check if there is a package restriction in a property file anywhere in your class path.

There is only one constructor for LoggingPermission that has two string parameters. The second can be null or an empty string, but it must be given. So try to enter null or “” in the policy file when giving a LoggingPermission.

Regards Gernot

I have add loggingPermission to the policy file with a notepad insteadof policytool,
but it still not work!!

I think perhaps the reason is not LoggingPermission,can anybody tell me what’s wrong?thanks.


Since even the AllPermission did not help, I think it is not the LoggingPermission or any other permission that is missing, but rather a security property “package.access” in a property file.

I please you again to check if there is a package restriction in a Java property file anywhere in your class path.

If this does not help, please contact your local dealer or the Tamino support.

Regards, Gernot