Error installing XSLT X-tension


I’m trying to install the XSLT X-Tension and i get this error:

INOSXE7114: Java error: java.lang.NoClassDefFoundError: com/softwareag/ino/sxs/XSLT/XSLT$SxsCallbackException

Something about jars?

Thanks in advance,


What version of Tamino are you using?

I just tried installing this using Tamino and did not have a problem.

I get the same error. I’m running version on Solaris.

Please try to append “.” (without quotes) to the public classpath. I had the same problem and this cured it.

Best regards,
Julius Geppert

Thanks. That worked for me.

Thanks, it’s solved! Something about version… ehehhehe :oops:


Hello there,

well even three years later I still get the same message. I think I’ve tried everything I could, but nothing helped. I’ve already tried the “.” at the end of the public classpath, putting Xalan into the subfolder java/lib/endorsed and even redirected java from the subfolder Tamino to my “normal” java installation (changed the link in the inosxbuilder_en.cmd) … without success. I can’t compile this extension nor can I install it at the server.

So I hope somebody could give me a hint how to set it up correctly.

The system:
Windows XP SP2
Java jdk 1.6.006
Xalan j271

Please help, Thx.

Hello forum members,

following this post I copied the Compile Command of the X-Tension Builder.

Placing it in a bat file it works fine, but in the X-Tension Builder it doesn’t. Also the installation in the Tamino Manager doesn’t work.

What am I missing?


The “.” mentioned in the classpath is referring to the database classpath. This is set via SMH. It corresponds to this setting in the registry:

HKLM\SOFTWARE\Software AG\Tamino\\SXS[java classpath]

are you sure that this has a “.” in it?

Once you have an Install.xml you should be able to build Java Server Extensions by hand using a compile of the form:

javac -classpath sxsrte.jar -d .
jar -Mcvf MySXS.sxp MySXS-dir Install.xml

Hello Mark,

thanks for your reply. Finally it worked out but it took some time before I understood correctly what to do with the dot. :wink: