Private classpath

Hi guys,

Does anyone know if there’s any problem with the private classpth of a SXS? When creating a new SXS, I specify the classpath using the X-Tension Builder, and I get this entry in the install.xml:
ExtendedClassPath="C:\Tomcat5\webapps\myapp\WEB-INF\lib\jdom.jar"

The proof that this works is that if you try to save the project with a diferenct location, the X-Tension Builder complains with a NoClassDefFound error. Of course, you cannot compile your xtension either.

The problem here is that even I specify a correct classpath, I can save and compile the project, when I’m trying to install the xtension, I get an error from the SMH, saying that there’s at least one class that cannot find (on the external jar). I have also tried to change the “” with an “/”, selecting the classpath when I’m trying to install the xtension, but nothing worked

The only workaround I’ve found so far for this issue is to set all jars needed in the public classpath. But I’m wondering if I’m doing something wrong…

Thanks a lot in advance!
Carlos

Ps: Tamino Version 4.2

I think that I may have a sneaky workaround that should help. It’s not too bad.

Make it so that the ExtendedClassPath=“jdom.jar”. Place a copy of “jdom.jar” in the “Tamino Server Extensions\Java” directory before installing the extension. I think that you should be able to install the extension without problems then.

It seems to work in my environment when I tried with log4j.jar.

Hi Mark,

Just a quick note to thank you for help and quick response. The workaround works fine.

Thanks again! Regards,
Carlos