SAX Exception

While executing a webservice that accepts ‘in0’ document, I get below error.
soapStatus = 1
SOAP-FAULT/faultcode = soapenv:Server.userException
SOAP-FAULT/faultstring = org.xml.sax.SAXException: Deserializing parameter ‘in0’: could not find deserializer for type {}BaseCaseValueObject.

could you please let me know the workaround. thank you.

This is not enough detail for anyone to be able to help.

How to request help to maximize useful responses

here is the webservice
CaseWebService.xml (8.28 KB)

Your post is still not descriptive enough. You have not described what your service on Integration Server is doing, what version you’re working with, what type of system you’re calling, what you’re passing, what you expect back, what you’ve tried to resolve this yourself.

Simply posting the SOAP fault and the WSDL and expecting meaningful feedback (beyond the obvious) is at best naive/inexperienced and at worst extremely lazy.

Looking at the wsdl it appears that your scenario is this:

  • You’re invoking a web service from Integration Server.
  • That web service is returning a SOAP fault.

The error is occurring in the web service hosted by a non-Integration Server. Looks like you need to talk to the people that wrote the web service to find out why they are throwing the exception.

It appears that you are attempting to invoke a soap-rpc web service from Integration Server. As mentioned here many, many times there are many known interoperability issues with soap-rpc, especially when the operations return arrays of custom objects as the operations described in your WSDL do.

The answer is not to generate java from the WSDL and invoke that as a java service, but rather to determine what a valid request messages looks like and then to come up with the least painful approach for sending that message to the service provider.

Remember, a web services connector is just a Flow service. It’s nothing special and you can easily duplicate what it is doing if you spend a bit of time examining what is going on.