'/sag/sag 97/Integration Server/instances/default/packages' locked when trying to delete folder


I am using SoftwareAG Designer 9.7 in Eclipse IDE. I logged in as admin and I use Subversive as SVN. But when I tried to create a package/folder/service under the default package, it will always say “cannot create …”. but then I ignore it and try to create it again, it will say such package/folder/service is already created.

So after refresh the package, I did see the newly created package/folder/service. But if I try to delete it, it will give this error.

Could not delete {0}
[ISS.0132.9117] error running command [svn, add, --non-recursive]; exit value: 1; output: [svn: Working copy ‘/sag/sag97/IntegrationServer/instances/default/packages’ locked, svn: run ‘svn cleanup’ to remove locks (type ‘svn help cleanup’ for details)]

I tried to launch the “svn cleanup” from WmSubversion, it will again say " [svn: ‘/sag/sag97/IntegrationServer/instances/default/packages/SampleWriteToFile’ is not a working copy directory]". But I don’t even have such package in my Package Navigator in the Eclipse IDE.

I have been struggling with this for quite a while. Any help is highly appreciated.

I’m confused. You say you’re using Subversive but later on you mention you’re using WmSubversion. Subversive is an Eclipse plug-in for Subversion and it’s typically used in conjunction with Software AG Designer Workstation (and other similar plugins), which is the newly recommended method for integrating webMethods with Subversion and other VCS.

WmSubversion is the old, server-side, approach of integrating with Subversion and I would strongly recommend against it. You should be able to find posts stating why here in the Tech Community.


1 Like


you should run the cleanup command from inside Designer if Subversive provides it.

On the other hand if you have a SVN client like i.e. TortoiseSVN installed on your box you can run the cleanup command from there, but you will to specify your workspace location in this case.