Replication on different PCs

Hello!

Software:
- Windows 2000 Pro + SP3
- Tamino 4.1.4

I have been working for replication on different PCs. On PC(1) I created database ‘mydb’, loaded schema, sample data and made a backup. After then on PC(2) I created database ‘mydb_rep’ from this backup.

On PC(1) in Replication Management of ‘mydb’ I executed command “Add Replication Database” and set database for ‘mydb_rep’.

On PC(2) in configuration file httpd.conf of Apache Web Server, I added the following lines:

<Location /tamino/mydb>
SetHandler ino
Host IP_OF_PC(1)
Port XML_PORT_OF_mydb


and of course, I restarted Apache service. After that on PC(2) I make a simple query:

http://localhost/tamino/mydb/col?_xql=doc (It is working!)

Now on PC(2) in Replication Management of ‘mydb_rep’, I executed command “Set Type To Replication” and set database to ‘mydb’. Unfortunately, I got the following errors:

-------------------------------------------------
Error code: INOAAE0668
Master database mydb must be active

Error code: INOAAE0665
Database mydb_rep can not be set as replication database
-------------------------------------------------

What should I do to make working replication management on different PCs?

In advance thanks a lot!

best regards,
Dariusz Baumann

Hi Dariusz,

> On PC(1) I created database ‘mydb’, loaded schema, sample data and made a backup.
> After then on PC(2) I created database ‘mydb_rep’ from this backup.

> On PC(1) in Replication Management of ‘mydb’ I executed command “Add Replication Database” and set database for ‘mydb_rep’.
Correct so far. However, you must make sure that mydb_rep is not started before you execute
"set Type to Replication" on it. You cannot set a database as replication database once it has been
started in normal mode.

In your case, I assume there is a different problem however. Obviously, mydb_rep cannot contact
mydb. It seems that you did not configure the same XTS directory server on both machines. If the machines do not share an XTS directory server, replication will not work.

Just as a remark: if you use XTS as communication method (which is not implied by my previous paragraph),
there is no need to modify httpd.conf or to
restart Apache.



Best regards

Harald

So, how to configure central XTS directory service?

regards,
Dariusz Baumann

Hello Dariusz,

You can check out the specific details in the documentation (x:\program files\software ag\extended transport service\doc\overview.htm). If you have two machines say MACHINEA and MACHINEB and want XTS centrally on MACHINEA then on MACHINEB you need to do the following:-
1) Stop your db(s)
2) Stop the “Software AG XTS Directory Service” service and disable it.
3) Modify the HOSTS file and change the entry for SAGXTSDShost to that of MACHINEA.

Now when Tamino databases are started, they will register using the central XTS directory service on MACHINEA.

Hope this helps.

Stuart Fyffe-Collins
Software AG (UK) Ltd.