Remote File Write

Trying to write a file to a remote server. But getting the error message " Specified Path is not on the write allowed list in the PSUtilities configuration file."

I tried modifying the config file but it does not write the file to another server.


I think you can use FTP to send this file to the remote server.AFAIK, utility services provided in PSUtilities package are to write to the local disk rather than to the remote servers.


On what platform are you running IS? If Windows, is IS running as a service? If so, what account is the service using? Does that account have access to network resources? Typically, IS as a Windows service runs as “Local System” and will not have privileges to access the network resources such as mapped drives or network shares (via UNC names) accessed via Windows networking.

IS version 6.1 on Windows 2003. IS is running as a service.

The account does have access to the server where I am trying to write a file. However I am able to pick up files from another server using polling service from admin console (port)

Ramesh - I do not want to use FTP to send it to a remote server.

I gave d:\temp as the allowed path allowed read, write and delete paths in PSUtils config file. When tried to simulate the problem, and when given the filename as first.txt, I got the same error. Try to give the full path name as of the allowed path and include the filename when writing,i.e, absolute pathname = d:\temp\first.txt.
Let me know if this helps.

I created a document type (XML) in TN. When I tried testing document type I am getting this message: " No document type matched this document. The funny thing is that this was working fine till last week.


Make sure the documentType is enabled and also see if any migration overwritten the doctypes section or could be your processing rule for sender/receiver/doctype is not working as expected and doctype is not recognized.

If this is working lastweek,then something might be changed in the TN environment or console.

Please elaborate what is ur current process and creation of your doctype (XML),rules etc…



I agree on what RMG said. To test the document on the TN use test option to make sure whether it’s picking the right document type and processing rule.



Having worked with PSUtils config files just one month I became exhausted. That is why I cloned all file services, put them into a new package and removed all calls to PSUtils.cfg file. Since then I am happy.
I recommend you to do the same.

Regards, Yevgen


ROB: [/i][/b]
IS version 6.1 on Windows 2003. IS is running as a service.

However I am able to pick up files from another server using polling service from admin console (port)



how you will poll the files in FTP server,If files are in local server we can poll by giving path like D:\Local for FTP how we can poll?
it’s a requirement in my project pls help me out.

The file polling port cannot be used to poll an FTP server. You will need to create your own service that uses the FTP services in pub.client to do the polling. If you have the EDI module, you can look at the VAN services for an example to follow.

thank you reamon, ya now i am doing same thing i created new service i invoked pub.client:ftp now it’s working.
and one more thing, for file polling in local system,we can poll files for particular time not for entire 24hrs a day? we have any options to set it in port.

I don’t think there is a way to do that directly. One approach might be to create scheduled tasks to enable the file polling port(s) during a given time window. For example, one task to enable the port(s), say at 8:15pm and another to disable the port(s) at 8:30pm. You’ll need to write the services that get invoked by the scheduler that enable/disable the appropriate port(s).

i have a question for you.I am trying to write/read a file on a shared location on a windows box and i am getting an Access Denied/Network path not found error.
But when I try to write the same file to some other windows shared location, it is writing and reading it fine.

FYI : My IS is running on a windows box as a service.

It is likely that the IS service does not have the permissions to access network resources. Work with your Windows sys admin to assign the appropriate permission to the IS service.