put document fails when passing from 4.1.4 to 4.2.1

May be this is lack of my tamino personal comprehension, but we have a strange problem with tamino, now that we are upgrading from version 4.1.4 to 4.2.1

Everything seems to work fine, but when we try to put a new document in a collection, the operation fails.
The error response from the activex is:


HAAXJE8400 HTTP Error 400, Bad Request, Unknown reason (xcmdisp.cpp,3735),

(nothing else)

We tried to put the same xml doc using the tamino X-Plorer (cut and paste, exactly “as the doc is”, from vba debugger) just to check if the xml was the guilty, and everything worked.

We do not understand why, but it seems that there is something different in the update procedure.

If we revert the db engine (we did many tests, either on machines with just the 4.2.1 and/or with the 4.1.4) to 4.1.4, then everything works,and we do not have problems at all (well… it has been working with 4.1.4 until now).

  • The ActiveX version is the 4.1.5 (20030703, seems to be the last).
  • All the machines are win2K, sp4, last windows updates (apart the msft malaware detection tool, all the crucial updates have been loaded and installed).
  • msxml is 4.0
  • we exeperimented the thing:

on 4.2.1 only machines
on 4.1.4 only machines
on 4.1.4 + 4.2.1 machines (straight install)
on 4.2.1 + 4.1.4 machines (reverted install)

Any idea?
thanks in advance for any suggestion.

Tamino 4.2 changed its behaviour so that an anonymous PUT would not be allowed.
There has been a recent hot fix to the ActiveX API that will do an implicit insert if the user attempts an anonymous PUT.
So you could either try a named PUT, an Insert or request the implicit insert ActiveX.

Thankyou Mark, we are going to check it.


I have the same problem,
where I can download hot fix for the ActiveX API?


Please contact support - SAGSIS P265310.
It is part of hotfix and will included in update kit