the items inserted through XQuery are deleted by the system,

I managed to add items into documents using XQuery tool using update insert statements(Interestingly these insert update statements don’t work on interactive interface giving error 8552, not a valid requiest, it is not possible to open a cursor with XQuery Update Request, but they work in the XQuery tool).
The problem is, after inserting these items, they appear for a few minutes, and they disapper :slight_smile:
why does this happen?
I see the inserted items from X-Plorer, and also querying the database using XQuery tool. But after a few minutes these updates are somehow deleted automatically.

Is this a bug or the things are wanted to be in this way due to some security constraints?

I will be glad if someone can inform me about inserting records into database,Is there any easier way to insert items into database?
I plan to insert some information from web to XML Server, and I want to use .NET framework.

Hello there.

This sounds strange! Maybe you are able to read the “dirty state” of the inserted documents before they are committed - but then the transaction is rolled back rather than committed…?

I will investigate this - could you please tell me which hotfix level you are using when this occurs?

(Although it might seem counter-intuitive, I think it is sometimes easier to work with the APIs than with the tools - because you have complete control over operations like transactionality [and a lot of the “nuts and bolts” are hidden in the APIs].
With a program you have written using one of the APIs, you know exactly when a document has been inserted and committed!)


Thanks you very much for your help. The problem arised two times, I inserted records but then after a few minutes they are gone, but after an hour, I tried again and at that time, it worked, and the system didn’t delete the records(about 15 hours passed, and the records are still there :slight_smile: )
And I didn’t notice same problem again. I have XML Server on a Windows 2000 Server machine. I don’t know about the versions of hotfixes :), but I know that only update installed is the X-Plorer update which was on the XML Server installation CD.

By the way, I also want to work things out with APIs, I am trying to develop things using .NET API of XML Server, my aim is being able to add records to XML Server, such as new people information etc. I think that I have to use XQueries to do that, but the ItemIterator object which was provided in the .NET API gives an error too, and I couldn’t manage to work with it too :slight_smile:
Even the sample which was installed with XML Server doesn’t work.

Hello there.

When you start a database in the System Management Hub you will see a message saying something like “Tamino server on Windows NT”.
The fourth digit is the patch level.

Which version of Java are you using to run the X-Plorer?

Could you not just use an insert method from one of the APIs to insert new documents, or is there a concrete reason preventing this?


The version of XML Server is displayed as
So I guess my batch version is 1.

About using API’s, that’s my main aim, I will use Tamino using .NET API, but I thought that it would be good if I do some practice to understand the system before developing things with API, also testing whether the things work fine.
Now I am using .NET API to do stuff on Tamino, but unfortunately I am having some problems with it too, as listed in .NET API discussion :slight_smile:

Thanks a lot for your help.