pub:client:smtp issue

Hello Everyone,

I installed WM9.9 in my local machine and i created a flow service to send a email to my Gmail account in that service i invoked pub:client:smtp and set value as follows-:
To- my email id
Subject- test mail
Mailhost- smtp.gmail.com
Mailhost port- i tried 25,587,465, but i got a error
In screen shot

Plz correct me where i am wrong

Thanks


did you try to set secure/transportLayerSecurity parameter to explicit, and also set the truststoreAlias?
you have to do that in order to use TLS to connect to a secure server.

Yes i did secure/transportLayerSecurity parameter to explicit its not working still can you brief how to set truststore alias?

thanks

You need to create a truststore (use java keytool or free tool like “Keystore explorer”), then configure truststore alias on Admin, then you can use it.
Refer to “Securing Communications with the Server” chapter in your IS admin guide.

Hi There,

Set the "watt.config.systemProperties" extended setting to "mail.imap.partialfetch=false,mail.imap.starttls.enable=true" on the "Settings > Extended" screen of the IS Admin page.

Restart IS if required. Kindly update your results.

1 Like