Pub.client:http is failing with Authorization exception for delete option

Hi Team,

We are facing an authorization issue while making a REST API call to Oracle service to perform delete operation using pub.client:http built-in service.

All other operations like GET/POST on that Oracle service are working fine with the same authorization details provided under service inputs of auth/user and auth/pass.

We tried using Postman to invoke the service for delete and it works fine. So this makes us think webMethods is failing internally somewhere to authorize to perform the delete operation on that oracle service.

One alternative way it worked for us with pub.client:http is using below setting in the extended properties below = Oracle user = Oracle pass

But we do not want to use this setting and instead pass the user credentials in service inputs of pub.client:http

Let us know if anyone faced this issue and how it got addressed.

This is on SAG version 10.3

Firoz N

Hi Team,

Any luck with the above issue, please.

Firoz N

Authorization issue? Do you have the logs in the debug mode and any messages logged during the service invocation at Oracle service?

Can you confirm if the delete operation is via query parameters in the URL or payload body? I have seen issues in the past with payload body.

Can you try the below workaround if that works for you! (it might not as it is a auth error)

  1. Set method=POST
  2. Under “headers” of the HTTP service call add: “X-HTTP-Method-Override”. Set the value=DELETE

Hi Mahesh

Thanks for your response. There are no many logs in debug mode at Integration Server end except the Authorization error. Oracle service is not getting the credentials we are passing in the input parameters auth/user and auth/pass in the pub.client:http.

We already tried the workaround you proposed and that didn’t work either.

The only workaround which worked is the one I said in the problem description.

Firoz N

That’s really strange! to isolate the issue, can you try running some tests on public API if it still fails then it is a really bug with that version of IS.