Proxy request for local edge without verified cert

Dear team,
I am working for the customize widget on cockpit.
For local testing, i start the server proxy to my local edge with domain myown.iot.com.
but fail to login, below is the error message I got.

[HPM] Error occurred while trying to proxy request /tenant/currentTenant from localhost:9000 to https://myown.iot.com (DEPTH_ZERO_SELF_SIGNED_CERT) (Errors | Node.js v18.5.0 Documentation)
[HPM] Error occurred while trying to proxy request /user/currentUser?auth from localhost:9000 to https://myown.iot.com (DEPTH_ZERO_SELF_SIGNED_CERT) (Errors | Node.js v18.5.0 Documentation)

Node.js keeps a separate list of certificates it trusts, so trusting the certificate on system level won’t help here, as Node.js won’t check against these.
You can add a specific certificate to be trusted by Node.js by creating the following environment variable: NODE_EXTRA_CA_CERTS with the value being the path to the certificate (you have to download it beforehand) e.g.: C:\Users\TBA\Downloads\c8y-iot-edge-de.pem

Another more insecure option would be to completely disable certificate validation by setting NODE_TLS_REJECT_UNAUTHORIZED environment variable to the value 0.

I set NODE_TLS_REJECT_UNAUTHORIZED=0 to fix this issue.