Proper way to move an ApplinX project (to another server)

What is the best way to move an existing project from one ApplinX server to another?

In older versions of ApplinX, the following was recommended (by Sabratec at the time):

(A) Create a “Configuration Only” export (GXZ) of the application. Then, stop the ApplinX service, and take a copy of the project’s ApplinX.MDB file.

(B) On the new server, set up the location the project will live in (e.g., C:\Projects<project>\db, and copy the “clean” ApplinX.MDB file (from C:\Program Files\Software AG\ApplinX\host-applications\New Application\db)

(C) Import the “Config Only” GXZ to create the project and have it refer to the newly created repository.

(D) Stop the ApplinX service, and replace the ApplinX.MDB with the one from the old server (with all the application code in it). Re-start the ApplinX service, open the Administrator and “synchronize” the database. And you’re ready to go!

I believe we did it this way because there may have been some problem with importing/exporting GXZ files.

Are all these steps necessary anymore? Or can we just create a “full” export (config + entities) from the first server, and just import the entire application into the new server?

We’ve been noticing a few cases where ApplinX seems to be losing some nodes in Path Procedures (e.g., the “MapScreen” nodes, and a few other mappings). We haven’t found a pattern to this yet, but want to make sure we’re transferring the application properly (as we move it from one server to another).

Thanks in advance.

Hi Tom,
We fixed some export/import issues we had in Applinx 5.2.4 - so the best solution I can suggest you is to upgrade to Applinx 5.2.4 HF4.
In HF4 all the import/export issues should be solved (hopefully ), and after the upgrade the right way to move the project would be to export your application (“full” export - configuration + entities), and then import it to the new server and importing the entities to your fresh DB there.

If you wish not to upgrade then I think the best way would be to continue working in the Sabratec way.
Keep me update about your choice and what if everything worked as desired,

Thanks Asaf. How do we go about getting HF4? Is that included under the customer’s license agreement? Also, we noticed one more “MapScreen” node (that we’re sure we had included in Path Procedure) disappear. Is that one of the problems specifically fixed by HF4? Thanks! Tom

Hi Tom,
First of all I mislead you. The Hot Fix you need HF5. :oops:
How you get it is something I’m not sure about - please contact the regular support channels.
About the missing node - I don

Hi Asaf - I’ll see if I can send you a GXZ, but I think I’ve figured out how the “MapScreen” nodes get lost (because it happened to me today!).

Start by creating a Path Procedure where you have a Step where source screen is “A” and target screen is “B”, and then have a “MapScreen” node anywhere after that Step where you are mapping things from screen B. You add lots of other logic, etc. and save the path procedure. All is well.

Later, re-open the Path Procedure to add another screen to the target side of the step (e.g., you find out that you might end up at screen “C” as well). So, now you have a step where you can go from screen “A” (source) to either screen “B” or “C” (the targets). If you save at this point, all the previously existing “MapScreen(B)” nodes look corrupted (i.e., when you select them, nothing displays in the lower section of the path editor). If you re-open the path procedure, you’ll now see that all the “MapScreen(B)” nodes have now vanished.

Do you know if this been reported? I’ll try to produce a GXZ and send it to you.


Hi Tom,
I don’t recall such a problem been reported before,
But also I cannot reproduce it here. (Although there is always the chance I misunderstood your instructions of how to reproduce it :slight_smile: ).
Please send me the GXZ of the path procedure before the disappearing of the node.

Hi Asaf -

I’ve attached a full repository export (GXZ file) that illustrates the disappearing “MapScreen” node. This is not our real application, but one called “TomTesting” that uses the AS400 testing host that ships with ApplinX

The location of my MDB file (for this project) is C:\Projects\TomTest\db\ApplinX.MDB … you can install it wherever you’d like.

There is only one path procedure in the project. If you open it up, you will see a step labeled “Step_1” that navigates from “SignOn” to “ApplinXDemoEnv”. Immediately after that step is one labeled “ScreenMapper_1” (that maps data from ApplinXDemoEnv to some of the path procedure output variables. So, this is the path procedure in a “good state”.

To simulate the proble, select “Step_1”, then select the “Multiple selection” icon to the right of “Target” screen, and add the “SignOn” screen to the set of “Target” screens and press “OK”. At this point, the “ScreenMapper_1” step becomes corrupt. If you then press “OK” to close (save) the Path Procedure, and then open it back up, you will notice that the “ScreenMapper_1” step has disappeared.

We are running ApplinX with no FP’s. Can you simulate the same behavior? We have seen this happen in several of our path procedures.

Tom (8.96 KB)

Hi Tom,
I liked the file name :smiley: but it is corrupted.
Did you change the extension from GXZ to ZIP?
If so it is not good, just take the GXZ and zip it.
If not, I don

Hi Asaf - It’s actually a ZIP file. Inside is a *.GXZ; the forum wouldn’t let me attach a GXZ file, so I zipped it.

Yes, I know that but still when I’m trying to open the zip file and extract the files out I get error message that this file is not a valid file and that’s why I need you to resend me the file you’ve created.

Hi Asaf - the ZIP file is not corrupt locally (i.e., before I upload it). I’ve tried in both Firefox and Internet Explorer, and end up with the ZIP corrupted (when I try to download it). Can I get it to you another way? (e.g., email). Thanks, Tom

Send it to my e-mail:

Hi Tom,
I was able to reproduce the problem very easily with the GXZ you sent me by mail.
I passed this issue to the R&D, so they can fix it and point me to the problem.
Thanks for the information,
I will keep you informed when the fix will be out.

Thanks for the reply Asaf!