program issued an ADABAS command without having issued an OP command - RSP 9 066

We have a COBOL program that performs an INSERT on a file. It bombs with a rc 9 subcode 66, indicating that an OPEN was not issued before the ADABAS command was issued (which is true, the only SQL in the program is the INSERT statement). it is called from a NATURAL program.

This program has been running successfully for years, up until we installed NATURAL (8.2.4) and ADABAS ( Apparently, something in one of these releases made a difference. The program hasn’t been execute in quite a while, so we can’t tell which of those caused the issue.

We tried adding a CONNECT statement, which works on the first call but then dies the next time the program gets called (the COBOL program is called within a loop). We tried modifying the code to do the connect only the first time the program is called, but then the second time it bombs with the 9 66 (not surprisingly really).

We could redo the program in NATURAL, but before we do something drastic i thought I’d ask if anybody has an idea on the cause/a fix. ?


Check if the OPENRQ parameter was modified from NO to YES (which is the default, btw) when ADABAS was upgraded.

Thanks for the response Wolfgang.

The DBA tells me it’s was “YES” before the upgrade.

looks like we might have a fix for this issue. i’ll post when i find out exactly what it was.