Problems using ''/invoke/wm.EDIINT/receive'

Hi everybody,

I’m trying to set up a test AS2 connection between two IntegrationServers (6.1) to get a feeling how everything works together. Both servers are running in my test environment (two separate servers).

I have written a testflow that is creating a UNEDIFACT document and passing it over to the ‘wm.EDIINT:send’ flow.
When i run the service on the Sender-Server, it looks alright in TN, i can see two documents, one ‘EDIINT’ and one ‘EDIINT MDN’, so it looks like the Receiver-Server has answered!
The problem is that i can’t see any document on the receiving side.

As ‘Location’ in the sender partner profile (under Primary HTTP) i have specified ‘/invoke/wm.EDIINT/receive’.
Ok, to check out what happens i have put a “save/restore pipeline” into the receive-flow to check the input values. The problem is, many input values are missing (e.g. protocol, message id, content type, …). The flow for example checks on ‘protocol’ and exits if it’s not available.

Finally i tried to use the ‘/invoke/’ as ‘Location’ instead of ‘’/invoke/wm.EDIINT/receive’. It works, but i think it’s not the way how i should do it! All samples and documentation i have found are using ‘’/invoke/wm.EDIINT/receive’.

Does anyone has an idea why this happens?

Many thanks for your help,
best regards,

A few thoughts:
1- Please confirm the Partner/receiver profile information on your sender server.
2- Check if you are indeed sending to the partner/receiver from your sending server and not to yourself (sender server to sender server)

Hi Taro,

Many thanks for your thoughts, i have checked both profiles and the IPs again, it looks alright.
Any other suggestions?

Best regards,

Is there anything in the logs on the receiving IS? Perhaps the ACL on the EDIINT:receive service is causing this.