problems in log4j(urgent!!)

I installed quip and the examplke quiries run fine, but when i run my own queries they dont work. It sometimes gives the error:
log4j:ERROR No appenders could be found for category (com.softwareag.common.inst
log4j:ERROR Please initialize the log4j system properly.
please help urgent!!!

I don’t believe there is much that can be done with regards to the log4j errors (I’ve tried and failed) but if you get an error it should be shown in the quipgui tool.

I don’t think the log4j messages indicate fatal errors. (To get around those, try placing a file like the enclosed one into the startup directory.)

I find that usually, the problem is an invalid file (located in your user-specific documents and settings directory). Exit Quip, move that file out of the way, and restart Quip. Does that work for you? (2.6 KB)

Sorry, I meant “quip.profile”, not “”, into which Quip saves the option settings when exiting.
Previous formats are not compatible to the current.

This thread looks a bit dead but I have the same problem ie:

Quip starts up OK but when a query runs, it puts the following text in the console window:

log4j:ERROR No appenders could be found for the category (com.softwareag.common.instrumentation.logging.Log4jLogger).
log4j:ERROR Please initialize the log4j system properly.

As far as I can tell, log4j is installed propoerly. I have put the suggested in the startup directory but still no joy.

It would be helpful to be able to log what is going on since the output window in Quip is not text that can be copied.

Any other places that I could look to solve this one?


I hope we’re discussing the same Quip version! (Mine is
– I don’t get the log4j messages (and if I did, I’d ignore them)
– If I switch the view to Plain, I can copy the output text.