Pluto Portlet Container & CAF

Hello,
I have tried to deploy CAF portlet into Pluto portlet container. I have already read the topic into advantage https://advantage.webmethods.com/advantage?targChanId=kb_home&oid=1614073579, done everything what is described but it still doesn’t work. Do I have to use Maven and to create the *.war file using the described structure into the official site http://portals.apache.org/pluto/v11/deploying.html or the information from advantage.webmethods.com is enough? After deploying the war file (using what is written into advantage) it throws an error.

Hi Mario,

Let me try to make a guess here.

The last sentence in the Pluto advantage article states the following:

IMPORTANT: To ensure your custom portlets will run in other portals don’t use non-portable JSF control library or any MWS specific API.

Maybe you are using non-portable JSF controls or a part of an MWS specific API without knowing?

A couple of suggestions:

  1. The best way to ensure you’re not using non-portable controls in your project is to select only ‘MwS Portable Controls’ JSF library during the project creation wizard. This will filter Palette view to show controls and beans from this library only. 95% of all Mws controls/beans are portable.

  2. ‘MwS specific API’ is anything packaged within Portal/lib/wm-caf-server.jar. It includes the following package spaces:
    com.webmethods.portal.*
    com.webmethods.rtl.*
    com.webmethods.jms.db.*
    com.webmethods.common.search.*
    If you’re using any classes from these packages then you’re using MwS specific API.

  3. Standard, i.e. out of the box or custom task portlets created from templates, do use non-portable controls and some MwS specific API’s. Plus they leverage proprietary portlet wiring and embedding as well as in-proc API to work with task engine. All of these make it impossible to re-use these portlets ‘as is’ in other containers.

Hope this helps,
Thomas

Hi, Thomas.

Thank you for the quick answer and for your suggestions of solving the problem. In my first post I meant is there any additional information from this that is described into the links, that I have to know how to deploy the war file into the portlet container. Any other steps that I have to do that are not included into examples?I tried to deploy an application directly from CAF Designer to Tomcat/Pluto container, when I set the server to use JSF 1.2 (Failed while installing CAF JavaServerFaces)and Dynamic Web Module 2.5, there are another errors. What could be the problem here? I am using JDK 1.6_07.

Regards,
Mario.

Hi Mario,

As far as I know there is no additional information that you need to be aware of.
JSF 1.2 is not supported, so that might be a problem right there.

Other than that I have no idea what the issue might be. Sorry!

Regards,
Thomas

Hi Thomas,

Thank you again for the previous and current information. I have solved the issue in a different way.

Regards,
Mario

I am curious: What was the issue / How did you solve it?

Thanks,
Thomas

Hi Thomas,
I am trainee into Bulgarian office. My task is to embed Application Designer into CAF. To do some communication between the two frameworks. I had to run CAF and Application Designer into one run-time environment and at first i thought that it is possible to deploy every portlet into Apache Tomcat/Pluto but my tries were unsuccessful. After that I understood that My webMethods Server contains Jetty container and I deployed CIS Application Designer into my webMethods server. I created an interface to be used as a way for communication between the two frameworks (Adapter class from Application Designers side and DefaultviewView from CAF part side implementing the interface). The interface is situated into jar file so that it could be used by CAF and Application Designer at one time. The jar is in \server\default\lib. There were some problems with NoClassDefFoundError because of classloading but now everything in this direction is OK. I want to use a defaultviewView instance into an Adapter and now there is problem with understanding and how to use this instance of DefaultviewView that is living into My webMethods Server. Do you have a solution of this problem?

I do not know if my description is OK but this is the clearest way that i can explain my situation. Thank you for reading this long post :slight_smile:

Best Regards,
Mario.