Passtrue and tamino on same machin

I have the passtrue running and after that I installed the webdav server now I have webdav running on port 4000 and passtru is running whit apache so the problem now is to get both of em to run whit apache I can only get one of them to run whit apache I think it is the problem that webdav installed its own tomcat server and I hade alredy one running so what do I do to get this up and running in the first tomacat server I installed the one whit passtrue???

Hope to get some good info here thanks to all that help out :wink:

You can make Apache communicate over mod_jk with both Tomcats (the one your are using for Passthru and the one comming with Tamino WebDAV Server [TWS]).

The easiest way to achieve it is to allow the mod_jk module used for TWS to communicate with Passthru as well:

1) in Apache’s httpd.conf, remove the “include …/apache-connector.conf” for the Apache-Passthru communication.

2) open the file xdav-apache.conf [located in /jakarta-tomcat/conf/jk] in an editor and add the following 2 lines for Passthru:
JkMount /examples/* ptr
JkMount /examples/servlet/* ptr

3) open the file [located in the same directory] in an editor and add the following 4 lines to add a new worker “ptr” for Passthru:
Moreover, modify the 2 lines listing the workers [“worker.list=ajp13” and “worker.loadbalancer.balanced_workers=ajp13”] to contain the new worker “ptr”:

Restart Apache and that’s all.

I am sorry for this late replay but hade a lot to do latly I now have the passtrue working fine but the webdav is still not on port 80 put on port 4000 so I dont know what is wrong now.

this is the replay I get from the server when I ask for the webdavserver

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.


Apache/2.0.43 Server at Port 80

[This message was edited by DBB on 03 Apr 2003 at 08:45.]

I hope some in here can still help me whit this setup as it is stil not working.
Any help is apriciated :slight_smile:


where did you got this error message? Starting WebDAV (Tomcat) or Apache?

Are you using the Tomcat deployed with WebDAV or your own TC?

Peter (our expert in TC/Apche config) is currently on holiday, how urgent would you consider this problem for you?

Best regards


I am using the TC that come whit Tamino webdav
and for passthrue I got TC 4.1
And it looks like the TC that come whit webdav have a problem when I recuest it I get this in the jk_log

I can wait to Peter come back I will also go on holiday later this week “O nice” :smiley:


could you please send your httpd.conf (located at Apache’s conf directory) and both files xdav-apache.conf and (both located at /jakarta-tomcat/conf/jk) so I can have a look at your configuration?

Also host names (if not “localhost”) and AJP ports for both of your Tomcats.


Ajp port is for the webdaw 4009 and the passtrue 8009

and thos are both localhost
I have attached the files (13 KB)

Your config files look all fine.

Probably the problem is that mod_jk-2.0.42.dll maybe is not compatible with Apache 2.0.43 (which is the version you are using).

Please try the following:
1) Download mod_jk-2.0.43.dll from or take it from attached ZIP file.
2) Stop Apache
3) Copy this DLL to your C:/Program Files/Software AG/Tamino/Tamino WebDav Server 4.1.1/jakarta-tomcat/bin/
4) Adapt the LoadModule entry in your xdav-apache.conf
5) Start Apache.

Peter (33.1 KB)

I have done this but still the same prob I still dont get acsses to webdav on port 80 true apache only on port 4000 :confused:

Hm … what now?

I’d suggest that you start again from the begining:
1) Have a clean installation of Tamino WebDAV Server (TWS)
2) If you did not disable is by custom install, TWS shoud be configured to run under Apache 2.0 now … so test it.
3) If it doesn’t work, try by substituting mod_jk-2.0.42 by mod_jk-2.0.43
4) If it still doesn’t work, tell me please.
5) Otherwise, you should now be able to access TWS over port 80.
6) Now add the configuration for Passthru in xdav-apache.conf and by configuring an additional worker “ptr”.

Good luck!

One more comment:

As I can see from jk_log entries you sent before, the connector receives socket error 61 (connection refused) when it tries to connect to port 4009 of TWS’ Tomcat.

Could port 4009 be busy on your machine? You can check with netstat /a. Maybe you could try with an alternate port (to be configured in Tomcat’s server.xml and in


Ok this you want belive but I did some funny stuff I made it so that the webdav server AJP port changed from 4009 to 8009 and the passtrue from 8009 to 4009 and then it worked :confused:

I am so happy but still joust as :confused: earlyer Man did any one say tomcat was easy to config and to locate what is wrong hehehe This was the funnyest thing in a long time at work :smiley:
Thanks for all your help but this one I dont think any one could have figuraded out :smiley: