Node js IS Connection

I am trying to work with wm-is-client

I am running IS locally on a different port (5503) and I have installed wm-is-client package globally (using -g flag). Now, I have updated the config file present in C:\Users<username>\AppData\Roaming\npm\node_modules\wm-is-client\lib\config.js with the updated port number and tried to list the IS packages using the command

is-client list

I am getting an error stating that there is no IS server running on default port (5555). Why is-client is not picking up the updated port number from the config.js file when the package is installed globally?
Capture.PNG

Try this is-client -s localhost:5503 -u Administrator -p manage list

Also, I was able to edit the file config.js and connect to the IS on the specifc port. Also, check the port Access/IP mode on IS.

Let me know if you have any questions.

Hi Mahesh,

Thanks for your reply. The issue is with the cli-test.js file in SoftwareAG wm-is-client repository. When we are not externally specifying the server port (using the flag -s), the serverport is set to “localhost:5555” and the serverport in config file is updated with the same during runtime. So, when we edit server and port in the config file and try to run the following command “is-client list” we get the above mentioned error because it looks for localhost:5555 where no IS instance is running.

P.S: I am sure that changing only the config.js and running the mentioned command won’t provide us with a positive output. I have tested it.

I have also attached snapshots of the code representing the same.

  1. (red colour) - code that is being present in cli-test.js
  2. (green colour) - my update on it. (I have also made a pull request for my update)

Regards,
Mowrish Dev
code.PNG
code_updated.PNG

Note: I dint get a chance to re-engineer the code myself.

I have a fresh setup on my local computer where I have installed Node.js runtime and followed the steps mentioned in https://www.npmjs.com/package/wm-is-client to install the required package.

I ran the command as-is on the default port 5555 on IS 10.5 and it works fine. Later I created another port 6666 with the required access mode, updated the config.js file and disabled the port 5555. It still works with the below config running on port 6666.

Try setting up again and it will work for you.

protocol : 'http:', // or https:

hostname: 'localhost',
// default request headers
headers: {
        'Accept': 'application/json',
},
port : 6666,

}
};