NoClassDefFoundError when deploying a web service

I’ve upgraded from Mediator 7.4.1 to 7.4.2 and I want to expose a mediator sequence as a web service. I managed to generate a web service, but when I try to deploy it, I get the following error message:

com.softwareag.xbridge.portals.PortalException: embedded exception: java.lang.NoClassDefFoundError

I haven’t found this error in the log files (neither in the folder C:\Software_AG\jboss-3.2.1_tomcat-4.1.24\server\default\log nor in the folder C:\Program Files\Software AG\EntireX XML Mediator\v742\host\logs)
So it’s difficult to guess which class the error refers to.
Changing the log level from “off” to “debug” doesn’t produce a log trace either.
I’ve tried the deployment from studio (in the web service creation wizard) and from the administraton console.
The webservice I’m trying to deploy is the “PriceQuote” example from the doc.

Any hint?
Thanks a lot,


Hi Robert,

This sounds like a possible version missmatch of the Axis libraries in the Web Server.

Do you have other WebService related products installed in the server? XML Gateways for instance. If so, what versions.

Let me know. :?

ok, it works now. I’ve removed the gateways and mediator that I had installed separately and I have reinstalled mediator with the ESI package setup.
Thanks a lot for your help.

I had the same problem and I really didn’t know what to do, until I visit this grate forum. Thanks a lot my friends.


Andres Y.