Need Help on Decoding Issue

Hi All,

I am using the below mentioned flow steps to decode an encoded string.But in the 2nd step(bytesToString) step,I am getting no output after conversion from byte to string.It seems base64Decode step is not creating proper object as expected .I am facing this issue in webMethods 8.2.But the same steps are working fine for the same input data in webMethods 6.5.

pub.string:base64Decode
pub.string:bytesToString

Please need help on this issue.

It looks like the issue specific to 8.2 env.

What fix level your IS is running on?

Can you try this way just to make sure its not decode problem?

-> pub.string:base64Decode
-> pub.document:bytesToDocument
-> pub.xml:documentToXMLString

HTH,
RMG

I tried with the below sequence of services, and found the output to be fine… I am running on 8.2.2 with IS Core Fix 8. As you said, this is executing fine in 6.5, I am assuming it is a different environment. In such case, are you sure the data that you are passing is base 64 encoded format?

stringToBytes
base64Encode
base64Decode
bytesToString

-Senthil

Thanks for the reply.
Sorry for not elaborating the issue properly.
There are two issues related to the above scenario.
1)Not getting output for byteToString service for a particular encoded data .
2)In the third step, a java service is called which encodes the string with the customized charset value.
We are getting the below error in this step for the encoding charset(begins with WM_) used in 8.2.But the same encoding charset is used in webMethods6.5 environment and the same service is working fine.
After analysing, I came to know that only “UTF-8” default encoding is being accepted in our webMethods8.2 environment .
So it seems we need to do some server side configuration to accept other charsets. Could you please let me know what changes we should make to resolve this issue.
Error-Unsupported Encoding Exception
RMG/Senthil-Thanks for your reply. I will check on Monday and let you know about the fixes applied in webMethods 8.2 env.

Saritha,

your comments are not related to this thread.

Please don’t post Jobs/training related material in any technical related sections.

Thanks for your understanding

RMG/Sendhil-Our working environment is 8.2.1.0.
Below are the fixes applied in this environment.
IS Core fix 8,DCC Fix ( DCC 8.2 SP2),SAP_7.1_Fix7

With Regards
Sweta

I would say please check with SAG support on this as you may need to upgrade to 822 core fixes or any server setting might bypass the default UTF-8

I am sure they can point you in the right direction:

HTH,
RMG

Thanks rmg for your suggestion.Our integration architect has already raised a ticket in software ag.If any resolution is provided,I will update in the forum.

With Regards
Sweta

When you invoke bytesToString service, you could see an input parameter ‘encoding’. You can set this to specific value or ‘autoDetect’.

You had also mentioned that, it worked in 6.5 whereas not in 8.2. May I know what Operating System you had in 6.5 and what you have now in 8.2? It actually depends on encoding supported by the specific Jvm used by that OS.

HTH
Senthil

A valid point raised by Senthil.So can you check and compare the underlying environments/JVM?

As suggested by Senthil,I tried to run bytesToString service by changing the input parameter ‘encoding’. Still the same issue is there.

SERVER ENVIRONMENT DETAILS:
In 8.2—Server env Setting- Java Version: 1.6.0_23 (50.0)
OS: SunOS
OS Platform: sparcv9
OS Version: 5.10
Updates: IS_8.2_SP1_Core_DiagCollector_PIE_24387_v04.jar;IS_8.2_SP1_Core_Fix8

In 6.5----ServerSetting --Java Version: 1.5.0_11 (49.0)
OS: SunOS
OS Platform: sparc
OS Version: 5.9
Updates: IS_6-5_SP3_Core_Fix2;IS_6-5_SP3_SrvPrtcl_Fix1;IS_6-5_SP3_WebSvcsXML_Fix1;IS_6-5_SP3_FlatFile_Fix1;IS_6-5_SP3_Flow_Fix1;IS_6-5_SP3_PubSub_Fix1;IS_65SP3_1-1YPPQQ_ENGFIX;IS_6-5_SP3;TNS_6-5_Fix49;TNS_6-5_Fix45;TNS_6-5_Fix43;TNS_6-5_Fix48;TNS_6-5_Fix46

What encoding type you are looking for?

All encoding starts with (WM_) .
WM_IBM-37_P100-1995

I tried to look for the encoding WM_IBM-37_P100-1995 and found nothing in google. Encoding appears as IBM-37_P100-1995. Why is WM_ prefix?

-Senthil

Senthil, nevermind. The problem is not with it, look above in the comments again.