Need help in trying to run API Gateway

Hi, I’ve been trying to get a new API Gateway API to work, but I’m not sure how it worked.

First, let’s imagine that in our situation, we have an API Gateway and Integration Server located in two different servers. We’ll call them ‘API’ and ‘IS’.

I created API from scratch, gave it GET Operation. It gave me a Gateway Endpoint. And my desired result will be: I invoke the API, and after going through the default policies, it will give out the result of:

http://{IS path}:{IS port}/invoke/pub.math:addInts?num1=1&num2=2 (It’s a built-in service in Webmethods).

So… where do I put the whole IS path as stated above, is it on the Native Endpoint or the Routing part of the Policy? Because when I tried to invoke the Gateway Endpoint, it gave out ‘Can’t find this page’…

Help appreciated. Thank you.

Based on your comments on the error message . I believe your server info containing a wrong base URI.

http://{host}:port}/{BaseURI}

Expected server info while creating scratch API as below

http://localhost:5555/invoke/pub.math:addInts

Your Endpoint URI should looks like below and resource path will have your query parameter at runtime.

@DINESH_J
When I tried mine, it gave the result “Requested Resource /add is not available”. How do we add that up in the Resources Method? (As in, after I added the resource name and path, what do I do to ensure that it gets me to that Endpoint URL?)

Thanks

Make ensure to ADD and save the resource and methods. if not spell check the URL which you are calling.

@DINESH_J I modified a bit of the link and it seemed to ‘work’, but not the way I intended: Instead of giving a ‘Not Found’ screen, it gave me a completely blank screen, empty result.

I wonder where did I go wrong in this?

Also in your screenshot, invokeInbuild is basically your API name? (And did you base it on the Gateway Endpoint?)

Export and share your API or provide the screen shot so that I could try to help if something is wrong .

Can you please specify what screens you want a screenshot at? I cannot give out the host name for legal reasons, so I had to censor a bit. So here’s the screenshots for Resources & Method, Native & Gateway Endpoints and Routing. Aside of those, nothing else were edited.



Attached the sample package try to see how yours is difference from the sample. if you still face issue or not able to achieve the way how you wanted. Share the error message instead of key word.

invokeInbuild.zip (4.4 KB)

This is meant to be exported to the API Gateway, right? How do I export this Zip file? I tried all options (OpenAPI, RAML, Swagger and WSDL) but all of them failed.

WSDL gave this message though

WSDLException: faultCode=OTHER_ERROR: Unable to resolve imported document at ‘/opt/softwareag/IntegrationServer/instances/default/temp/1637722655065//null’.:java.io.FileNotFoundException: This file was not found: file:/opt/softwareag/IntegrationServer/instances/default/temp/1637722655065//null

My OS is Windows 10, FYI.