NaturalOne on Unix - cannot execute 3148 database 1 not active subc 0

Hello, I am unable to right click and select ‘Execute’ against simple adhoc programs that read our Adabas database from our test environment. However, for some reason in our production environment we get Nat3148 Database 1 not active. They are running on different machines. We are currently executing NaturalOne and legacy Natural Editor. We are trying to get completely off Natural Editor as requested. Please advise if you know would cause this.

The connection properties in NaturalOne is the same. Meaning session properties contains webio=on for both.

You’ll have to provide some more details…

  • are you saying your adhoc program does not work in test? If so, what happens when you click “execute”?
  • So…production database and test database are on different servers? Where are your Natural environments - on the same servers as the database? Is NDV running on both servers? Is there a database 1 on the production machine? Was the program recompiled (catlog/stow) on the production server? Was it compiled with a DDM that has a hard coded dbid 1 on it? If not (using dbid=0), what is the UDB setting for the NDV server you are connected to? (you can override it dynamically in session parameters)
  • if you have NDV only on one server (test?), do you have Entire Net-Work or Adabas TCP enabled for cross-machine communication (from prod machine to test machine?)?

Thank you Douglas. I have reached out to our primary contact who works directly with SAG with some of your questions and pointers. Our primary person, Alex, has retired from SAG so we are trying to determine our next primary contact.

Thank you