Natural One just installed : Application Server type is missing

What product/components do you use and which version/fix level?

Win 10 X64 / N1 9.1.4 / Designer 10.11

Are you using a free trial or a product with a customer license?

the latter

What are trying to achieve? Please describe in detail.

trying to execute a 1 line program

Do you get any error messages? Please provide a full error message screenshot and log file.

‘Launching Default Launch’ Application server type is missing

If you are just clicking on the Run As icon (green triangle), you need to right-click on your program and select Run As…Natural Application at least once to set the “Default Launch” to something. Once that is done, you should be able to repeat the last Run As with the Run As icon.

See about 2:03 in the “First Steps in NaturalONE” tutorial (First Steps in NaturalONE)

If that’s not the issue, please include the screenshot and the steps you are taking that lead up to the error.

Hi Douglas,
thankyou for the reply.


I have been a user of mainframe natural for 30 years but am a bit slow with the Eclipse IDE.
My error reports Vilmos [ thats the name of a remote sever in Melbourne, I am in Belfast] not available but just a few minutes ago I clicked down in the Natural Server window [lower LHS window ] and expanded the User libraries tag & saw a library Graham created by an associate in Australia. So I am sure I have connectivity to ‘talk’ to the remote server but not it seems when I need to execute ,
thanks for assistance,
Trev

Hi here are two screen shots of detail in the run configuration . . .


the error is saying it can’t find the host “vilmos-2700(1)”. The Natural Server connection information provides a suspect Host name. If the host is “vilmos” then just put vilmos there. The port number (2700) is entered in its own input field and NaturalONE puts them together in a name, but it is accessing vilmos:2700 (that is, host vilmos, port 2700).

Hint: In the context menu of the project, Natural > Runtime, use the “Use Natural server” selection. Then you can be sure that your project uses the same setting as the server view.
Afterwards you can use the Run as > Natural application, so that the Default Launch is set (as described by Douglas).

Hi Lukas, thankyou,
I think we have made a little progress.
I have attached 4 pictures

  1. what it was like at the start
  2. is after I took your suggestion to “use Nat Server”
  3. Is new error 'pgm not found"
  4. Is my environment.

I think the problem now is I am looking / executing from the remote server and it is telling me the program does not exist there & indeed it doesn’t .
So now I have two options
1st exec it locally OR 2nd to push the program up to the server ; both would be useful to be able to do
thanks
Trev


Sag-15th-3

Trevor,

you will need to push the object to the server.

I don’t see TREVLIB in the server view, does it exist there ?

To push the object, either right-click PGM1 → NaturalONE → Update or press Alt+T

Cheers - Wolfgang

Hi Wolfgang, long time no chat : thanks, I do believe we are getting close. I had previously tried to upload PGM1 and although the dialogue showed progress messages as in “… uploading” I would have expected to eventually see TREVLIB as a library listed beneath GRAHAM under “User Libraries”. This leads me to think perhaps I do not have the permissions to create a Library on the remote target – which I will follow up separately. So then I created PGM2 but chose to save it into library GRAHAM and upload it and this worked ; I can see PGM2 within Lib GRAHAM. However trying to list or execute it results in either

connection to host vilmos, port 2700 failed or
The specified host vilmos is not accessible

Hi,

I think you should look 1st at your Linux Fuser permissions, 2nd your ndv process configuration, 3rd your natparm configuration.
If you have a Natural Security, so you should look into it as well

Hi Trevor,
the NaturalONE decorators indicate the status of object. For your PGM1, it says that it is neither uploaded nor updated. The “Run as” executes the cataloged object on the server. This is not the same as a RUN in other environments in which the source is “executed”. An “Upload” saves your source on the server, an “Update” saves it on the server AND catalogs it there. If the decorators are set and you run the program, you can run into the error “not found” if the program was never updated (stowed) on the server. If it has been stowed before, you will execute an old version of the code (which might be worse). In general, I would recommend to use the “build modified objects” button before you run a program. It updates all modified objects of the current projects in the expected sequence.
Of cause, a library must be defined in NSC if security is used. But that is the same as in other environments.

Hi Lukas,
thankyou, I think we are there ; I need to learn the nomenclature ; I could not seem to create my library TREVLIB on the Natural Server but an associate who installed the server created it for me & then I was able to upload my program ; it wouldn’t exec so I stowed and it has just run/ executed successfully.
Thanks everyone ; note this may not be the last you hear from me but enjoy the festive break,
regards,
:):):slight_smile:
Trev

all done thanks

you are welcome :slight_smile: