MWS not starting after applying Fixes


I currently try to install 2 MWS instances 9.5 SP1 on two different systems with a reduced set of UI´s (Monitor, TaskEngine, Business Rules) applied.
One System is Solaris SPARC version 10 and the other one is Solaris SPARC version 11.
Both versions are failing when applying Fixes to the MWS installation.
UpdateManager looks fine so far, but MWS is no longer able to start afterwards.
Instead it is throwing NoClassDefFound errors, as well as Exceptions regarding “unable to load bundles”.

Work done so far:

  1. create a DB schema
  2. install MWS and other neccessary products
  3. Adjust configuration (i.e. jvm, certificates, java memory)
  4. Start MWS
  5. complete configuration in MWS UI
  6. Shutdown MWS
  7. Apply the fixes using UpdateManager
  8. Start MWS

Point 8 is not completing, instead the processes are being shutted down due to the mentioned loading errors.

Do any one of you have any ideas, what is going wrong and how to overcome this?

Support Team and R&D are already involved and they are investigating this for nearly 6 months now.
But unfortunately there is no solution until now.



Have you updated the JVM? It needs a special procedure.

The DB update went ok?

Did you first run the -s <server> update before running the MWS? Keep another terminal screen open with the tail -f _full_.log.

Check if the you don’t have any errors when reading the certificates keystores.

Best Regards,
Gerardo Lisboa

Hi Gerardo,

thanks fior your response.

No DB-Update neccessary here as it is directly using the right schema version (40 for MWS 9.5 SP1) for the set of Fixes to be applied.
No DB issues could be observed here yet.

Certificate Stores are fine as they follow a specific password scheme which is the same on instances (either IS or MWS).

Primary MWS instance having a full set of UI´s applied (addtionally Messaging, IS-Portal, Optimize and TradingNetworks) could be installed and patched successfully on both environments.

As these are fresh installations in dedicated directories the update command should either be done automatically by the Installer or the UpdateManager as part of their tasks.

Server name is always default.

I will do another check when I will be able to use a newer Set of Fixes incl. a newer OSGI-Fix as there seems to be an issue when updating bundles.


Faced the same issue for wM9.12 but couldn’t resolve it. Tried many things but to vain.
Fortunately it was development server. So, we reinstalled the MWS instance and it worked fine after that.

Update us in case you find any resolution.

Syed Faraz Ahmed


Check to see if there any updates to the DB components and apply them.

Then restart the mws in “update” mode.

It should take 30min to 1 hour.

After that start the MWS normally but follow the full.log for any problem.

Best Regards,

Hi Gerardo,

I have recently applied DC_9.5_SP1_DBS_Fix8 to my local installation and checked the file.

It still refers to the Version 40 for MyWebMethodsServer.

As pointed out previously the restart in update mode is done by UpdateManager and there are no issues in the logs during this.

Only after starting normally the next time MWS throws a lot of exceptions and errors in different logs and the java processes are gone after a certain moment as initialization of MWS cannot complete due to the mentioned issues.



Could it be your system does not have enough memory to hold your MWS instance?

How much memory do you have before starting MWS?
How much is the MWS requiring?

Keep a system memory monitor open to see what happens.

Best Regards,