MWS Migration Utility failing during establishing SQL DB connection with Window Authentication ntlm

I am performing MWS migration from 10.5 to 10.15 .

Have migrated MWS cloned database to latest version using configurator and it migrated successfully.

After that during MWS default server migration using migration utility(migrate.bat),

Migration utility not able to establish db connection and giving error as below

07:52:29.355 [main] ERROR com.webMethods.portal.service.sql.core.provider.pool.ConnectionPoolManager - Error creating database connection to:
jdbc:wm:sqlserver://(SQL Database Server Name):Port Number ;databaseName= ();AuthenticationMethod=ntlm

java.lang.NoClassDefFoundError: org/apache/derby/shared/common/security/SystemPermission
at org.apache.derby.iapi.jdbc.AutoloadedDriver.connect(AutoloadedDriver.java:134) ~[com.springsource.org.apache.derby_10.15.2.0.jar:?]
at java.sql.DriverManager.getConnection(DriverManager.java:677) ~[java.sql:?]
at java.sql.DriverManager.getConnection(DriverManager.java:228) ~[java.sql:?]
at com.webMethods.portal.service.sql.core.provider.pool.ConnectionPoolManager.create(ConnectionPoolManager.java:159) [com.webMethods.caf.server_10.15.0.0000-0385.jar:10.15.0.0000-0385]
at com.softwareag.mws.migrate.util.DbUtil.openDBConnection(DbUtil.java:187) [wm-mws-migrate.jar:10.15.0.0000-0385]
at com.softwareag.mws.migrate.cmd.CmdServerNodeMigratorClient.testDbOptions(CmdServerNodeMigratorClient.java:367) [wm-mws-migrate.jar:10.15.0.0000-0385]
at com.softwareag.mws.migrate.cmd.CmdServerNodeMigratorClient.setDbOptions(CmdServerNodeMigratorClient.java:313) [wm-mws-migrate.jar:10.15.0.0000-0385]
at com.softwareag.mws.migrate.cmd.CmdServerNodeMigratorClient.gatherServerNodeData(CmdServerNodeMigratorClient.java:248) [wm-mws-migrate.jar:10.15.0.0000-0385]
at com.softwareag.mws.migrate.cmd.CmdServerNodeMigratorClient.gatherData(CmdServerNodeMigratorClient.java:168) [wm-mws-migrate.jar:10.15.0.0000-0385]
at com.wm.app.b2b.server.migrate.MigrationDriverLite.gatherMigrationData(MigrationDriverLite.java:334) [wm-is-migration-framework.jar:10.15.0.0000-0674]
at com.wm.app.b2b.server.migrate.cmd.CmdLineToolMigrationDriver.execute(CmdLineToolMigrationDriver.java:478) [wm-is-migration-framework.jar:10.15.0.0000-0674]
at com.wm.app.b2b.server.migrate.cmd.CmdLineToolMigrationDriver.processMigration(CmdLineToolMigrationDriver.java:668) [wm-is-migration-framework.jar:10.15.0.0000-0674]
at com.softwareag.mws.migrate.cmd.CmdMWSMigrationDriver.main(CmdMWSMigrationDriver.java:339) [wm-mws-migrate.jar:10.15.0.0000-0385]
Caused by: java.lang.ClassNotFoundException: org.apache.derby.shared.common.security.SystemPermission
at jdk.internal.loader.BuiltinClassLoader.loadClass(BuiltinClassLoader.java:581) ~[?:?]
at jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(ClassLoaders.java:178) ~[?:?]
at java.lang.ClassLoader.loadClass(ClassLoader.java:522) ~[?:?]
… 13 more

I’ve provided db alias as below ,

jdbc:wm:sqlserver://(Database Server Name):Port Number ;databaseName= ();AuthenticationMethod=ntlm

I’ve also provided DB user name and password in utility.

Same alias was worked fine during run of DB configurator but failing to establish db connection using migration utility.

Also, I’ve checked all permission from db side and mws server side and provided required permissions.

Also,I’ve tried to run without the AuthenticationMethod=ntlm and getting same error.

This issue I am only facing during execution of MWS migration utility.

Same DB alias of MWS cloned DB is working in case of IS migration from 10.5 to 10.15.

Can anyone help on this further?

Could you please attach the mws.db.xml file?

db xml.txt (1.2 KB)

Hi Meglena,

Attached copied db xml file from 10.15 MWS Default directory MWS\server\default\config.

URL is in this format–>
jdbc:wm:sqlserver://(Database Server Name):Port Number ;databaseName= ();AuthenticationMethod=ntlm

Also user name and pass is there in original file.