MWS left navigation 'Tool' has error while refreshing

Dear Experts,
In My local system , i am facing a problem while refreshing Tools menu in Left side navigation. While clicking on refresh link 'Tools’s section ,there is null pointer exception. it’s restricting me to add any portlet to the page.

Kindly suggest how to fix it. please find attached error snapshot

Error Message -
[POP.001.0002] A “java.lang.NullPointerException” occurred with the Message “at com.webmethods.portal.framework.portlet.beans.BasicPortletBean.createPortletURL(BasicPortletBean.java:747)”

MWS URl - http://localhost:8585/meta/default/wm_xt_fabricfolder/0000006914?layout=folder&shell=shell.noodle.editor&returnUrl=%2Fmeta%2Fdefault%2Fwm_xt_fabricfolder%2F0000006914

Version - 9.5.1.0.93

Please check for your MWS settings under the following path:

Administration -> My webMethods -> Cluster Settings

In tab “Advanced or Clustered Configuration” there is an entry “MWS Front End URL” and an entry “Host”.

Both should point to the same name, i.e. localhost or some Name of the PC (can be checked by “ipconfig -a” in a command window).

You need to restart the MWS after changing these values.

Regards,
Holger

Thanks Holger for prompt response,
I found that host names were different , so i corrected them and restarted the server. But still it has same error while refreshing the Tools section.

In this case: Bad Luck.

Regards,
Holger

Rohit,

Can you share screenshot of your settings. I guess there might be some issue there.

Thanks,

Thanks,
Can you please guide me which configuration should i share ?

Hi Rohit,

I was referring below details :

Administration -> My webMethods -> Cluster Settings

In tab “Advanced or Clustered Configuration” there is an entry “MWS Front End URL” and an entry “Host”.

Thanks,

Dear , please find the configuration as in attached document.

Interesting Screenshot.

Please change host and frontend url to the value of the node name (the section before the “-nodeXXXX”).

This should solve the issue.

This has something to do how the names and IPs are resolved.

Regards,
Holger

Hi There,

your URL should be : W01PISVDI022.corp.tmnas.com
Host should be : W01PISVDI022.corp.tmnas.com

Please try with above options and let us know the result.

Thanks,

Thanks both, i have changed url multiple times but then after Submit action , it automatically change to ‘localhost’ which is weird.