MWS Installation Error 10.3

Hi All , I am getting multiple errors when installing MWS. Can someone please help me out with this.

wrapper | Base configuration file is C:\SoftwareAG\profiles\MWS_default1\configuration\wrapper.conf
wrapper | Found #include file in C:\SoftwareAG\profiles\MWS_default1\configuration\wrapper.conf: C:\SoftwareAG\MWS\bin\wrapper-license.conf
wrapper | Reading included configuration file, C:\SoftwareAG\MWS\bin\wrapper-license.conf
wrapper | Found #include file in C:\SoftwareAG\profiles\MWS_default1\configuration\wrapper.conf: %OSGI_INSTALL_AREA%/configuration/custom_wrapper.conf
wrapper | After environment variable replacements: C:\SoftwareAG\profiles\MWS_default1/configuration/custom_wrapper.conf
wrapper | Reading included configuration file, C:\SoftwareAG\profiles\MWS_default1\configuration\custom_wrapper.conf
wrapper | --> Wrapper Started as Console
wrapper | Java Service Wrapper Standard Edition 64-bit 3.5.32
wrapper | Copyright © 1999-2017 Tanuki Software, Ltd. All Rights Reserved.
wrapper | http://wrapper.tanukisoftware.com
wrapper | Licensed to Software AG USA, Inc. for Software AG My webMethods Server
wrapper |
wrapper | Launching a JVM…
jvm 1 | WrapperManager: Initializing…
jvm 1 | Debug options:
jvm 1 | file:/C:/SoftwareAG/profiles/MWS_default1/configuration/.options loaded
jvm 1 | !SESSION 2020-10-22 15:29:42.677 -----------------------------------------------
jvm 1 | eclipse.buildId=unknown
jvm 1 | java.version=1.8.0_181
jvm 1 | java.vendor=Azul Systems, Inc.
jvm 1 | BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_IN
jvm 1 |
jvm 1 | !ENTRY com.softwareag.platform.hook.locations 1 0 2020-10-22 15:29:43.223
jvm 1 | !MESSAGE Registering the location resolver hooks.
jvm 1 |
jvm 1 | !ENTRY com.softwareag.platform.hook.mirrors 1 0 2020-10-22 15:29:43.225
jvm 1 | !MESSAGE Registering the mirror bundle management hooks.
jvm 1 |
jvm 1 | !ENTRY com.softwareag.platform.hook.shutdown 1 0 2020-10-22 15:29:43.230
jvm 1 | !MESSAGE Registering the shutdown hook.
jvm 1 |
jvm 1 | !ENTRY com.softwareag.platform.hook.locations 1 0 2020-10-22 15:29:43.730
jvm 1 | !MESSAGE Discovered location: osgi.user.area=file:/C:/Users/Roshan/user/
jvm 1 |
jvm 1 | !ENTRY com.softwareag.platform.hook.locations 1 0 2020-10-22 15:29:43.731
jvm 1 | !MESSAGE Discovered location: osgi.instance.area=file:/C:/SoftwareAG/profiles/MWS_default1/workspace/
jvm 1 |
jvm 1 | !ENTRY com.softwareag.platform.hook.locations 1 0 2020-10-22 15:29:43.733
jvm 1 | !MESSAGE Discovered location: osgi.configuration.area=file:/C:/SoftwareAG/profiles/MWS_default1/configuration/
jvm 1 |
jvm 1 | !ENTRY com.softwareag.platform.hook.locations 1 0 2020-10-22 15:29:43.734
jvm 1 | !MESSAGE Discovered location: osgi.install.area=file:/C:/SoftwareAG/profiles/MWS_default1/
jvm 1 |
jvm 1 | !ENTRY com.softwareag.platform.hook.locations 1 0 2020-10-22 15:29:43.735
jvm 1 | !MESSAGE Discovered location: eclipse.home.location=file:/C:/SoftwareAG/profiles/MWS_default1/
jvm 1 |
jvm 1 | !ENTRY com.softwareag.platform.hook.locations 1 0 2020-10-22 15:29:43.741
jvm 1 | !MESSAGE Replacing system property java.security.auth.login.config->@url:osgi.configuration.area/jaas.config with java.security.auth.login.config->file:/C:/SoftwareAG/profiles/MWS_default1/configuration/jaas.config
jvm 1 |
jvm 1 | !ENTRY com.softwareag.platform.hook.locations 1 0 2020-10-22 15:29:43.744
jvm 1 | !MESSAGE Replacing system property sag.install.area->@url:osgi.install.area/…/… with sag.install.area->file:/C:/SoftwareAG/
jvm 1 |
jvm 1 | !ENTRY com.softwareag.platform.hook.locations 1 0 2020-10-22 15:29:43.753
jvm 1 | !MESSAGE Discovered location: sag.install.area=file:/C:/SoftwareAG/
jvm 1 |
jvm 1 | !ENTRY com.softwareag.platform.hook.locations 1 0 2020-10-22 15:29:43.755
jvm 1 | !MESSAGE Registered location sag.install.area=file:/C:/SoftwareAG/
jvm 1 | [Thu Oct 22 15:29:43 IST 2020] Bootstrap: Initialized shutdown handler to com.softwareag.platform.hook.shutdown.HookConfiguratorImpl$$Lambda$1/1485682834@6a607f46
jvm 1 |
jvm 1 | !ENTRY com.softwareag.platform.hook.shutdown 1 0 2020-10-22 15:29:43.821
jvm 1 | !MESSAGE Initialized graceful shutdown handler.
jvm 1 | Oct 22, 2020 3:29:44 PM com.softwareag.platform.console.internal.LocalConsoleManager open
jvm 1 | INFO: Local JLine console flag: com.softwareag.platform.console.local.enabled=auto
jvm 1 | Oct 22, 2020 3:29:44 PM com.softwareag.platform.console.internal.LocalConsoleManager open
jvm 1 | INFO: Local JLine console disabled: JVM not attached to a terminal.
jvm 1 | log4j:WARN No appenders could be found for logger (com.softwareag.security.config.filter.jaas.ldap.lm.internal.Activator).
jvm 1 | log4j:WARN Please initialize the log4j system properly.
jvm 1 | log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for more info.
jvm 1 | Oct 22, 2020 3:30:04 PM com.softwareag.platform.logging.init.internal.Activator start
jvm 1 | INFO: Setting configuration directory to C:\SoftwareAG\profiles\MWS_default1/configuration
jvm 1 | Oct 22, 2020 3:30:04 PM com.webmethods.sc.config.ConfigurationLogger log
jvm 1 | INFO: Out-of-band file changes will be monitored every ‘60000’ milliseconds
jvm 1 | Oct 22, 2020 3:30:04 PM com.softwareag.platform.logging.init.internal.Activator start
jvm 1 | INFO: Initializing Journal Logger with the greedy JUL bridge
jvm 1 | [Thu Oct 22 15:30:09 IST 2020] Bootstrap: Stopping…
jvm 1 |
jvm 1 | !ENTRY com.softwareag.platform.hook.shutdown 1 0 2020-10-22 15:30:09.764
jvm 1 | !MESSAGE Stopping OSGi framework.
jvm 1 |
jvm 1 | !ENTRY com.softwareag.platform.hook.shutdown 1 0 2020-10-22 15:30:09.770
jvm 1 | !MESSAGE Framework shutdown timeout set to 120 seconds. Please also check tanuki-wrapper shutdown property, if specified.

Regards
Roshan

Hi Roshan,

I cannot see any errors here,.

MWS takes some time upon first startup to complete database initialization and user creation.

Are there any messages in the C:\SoftwareAG\MWS\server\default1\logs\_full_.log which might contain further informations?

Regards,
Holger

Hi Holger,

Thanks for replying. I cannot see full_.log file. Attached the screenshot for your ref.Could this be some installation issue ? I have tried installing it multiple times and I get the same error.

Please suggest.

Hi Roshan,

might be an issue with the instance name of the MWS server.
Usually it is just default and not default1.

Did you check the content of these XML files for any messages?
Esp. errors.xml might be of interest here.

Did you try to apply latest Fixes to your MWS installation?
Eventually this will solve certain things.

Which database are you using?
Where the database schema for MWS component created on this?

Running MWS with an Embedded database is only supported for very few use cases as far as I know.

Regards,
Holger

Hi Holger,

I used default1 as a sample, default didnt work either.

errors.xml does not contain anything useful

Where can i get the latest fixes to install to MWS?

Database i am using in oracle11g .

Hi Roshan,

do you have UpdateManager installed on your side?
UpdateManager is a separate installation (no longer bundled with the base installation image) used to download and install fixes.

Regarding Database you should check if you can update to 18c or 19c.

Regards,
Holger

1 Like

Can you please check platform and sag-osgi logs under /profile/MW_instance/logs
Do you see any related errors there?

1 Like