MWS Applications Menu stays emtpy

Hello,

i tried around with adding own applications to the Applications menu in MWS and I added and deleted a custom page. After deleting this page from “My webMethods Applications”/“Fabric Tasks” the Applications menu stays empty after login into MWS. The log shows the following entry:

javax.jcr.ItemNotFoundException: Item not found: /meta/default/wm_xt_fabricfolder/0000014889
        at com.webmethods.jackrabbit.spi2mws.MwsRepositoryService.getNodeInfo(MwsRepositoryService.java:1265)
        at com.webmethods.jackrabbit.spi2mws.MwsRepositoryService.getItemInfos(MwsRepositoryService.java:1288)
        at org.apache.jackrabbit.jcr2spi.state.WorkspaceItemStateFactory.createDeepNodeState(WorkspaceItemStateFactory.j
ava:106)
        at org.apache.jackrabbit.jcr2spi.state.TransientISFactory.createDeepNodeState(TransientISFactory.java:109)
        at org.apache.jackrabbit.jcr2spi.hierarchy.UniqueIdResolver.resolve(UniqueIdResolver.java:75)
        at org.apache.jackrabbit.jcr2spi.hierarchy.HierarchyManagerImpl.getHierarchyEntry(HierarchyManagerImpl.java:106)
        at org.apache.jackrabbit.jcr2spi.SessionImpl.getNodeById(SessionImpl.java:260)
        at org.apache.jackrabbit.jcr2spi.SessionImpl.getNodeByUUID(SessionImpl.java:233)

.

So how can I delete /meta/default/wm_xt_fabricfolder/0000014889?

Any help is highly appreciated.

Thanks,
Mathias

Hello,

i found that I have an entry with the ID 14889 in the table TBLTHING. The field ISDELETED was set to ‘1’. I set this to ‘0’. And after restarting the server I receive the following exception instead of the one described above:

2010-07-29 09:21:21 CEST (jsf:ERROR) [RID:86] -
javax.jcr.ItemNotFoundException: cannot read item /meta/default/wm_xt_fabricfolder/0000014889

So this seems to be a step forward. But still the applications menu stays empty. Any ideas how to repair this?

Regards,
Mathias

It seems likely that you deleted a root node in the Applications Taxonomy. What i would recommend doing is redeploying the wm_fabriccontent.pdp. This will re-install the base skeleton of the navigation folders.

However, if you have deleted a root folder, then all the other application folders will have been deleted as well in which case those application folder must be redeployed. Depending on what UI products you have installed, there will be many different pdp components to be redeployed.

Hello,

thanks for the reply. In the meantime the support solved the issue.

By specifying a wrong xmlImport.xml file in my project I accidentally overwrote the alias webm.fabric.tasks.root with a target I later deleted. So restoring the alias resolved the issue.

I did the following:
1- Log in as SysAdmin.
2- Navigate to Folders > Administrative Folders > Administration Dashboard > Configuration > Alias Management
3- Search for alias webm.fabric.tasks.root
4- Click on “Edit” and select “New target: resource”
5- Click on “Browse button” and navigate to “Folders” -> “My webMethods Applications”
6- Now do not click on “Fabric tasks” but click on the right arrow for ir, so the name moves to the right frame for the “Selected component”. Now click on “Select”.
7- Ensure name is displayed as “Fabric tasks”, and update alias.

Regards,
Mathias