MWS 7.1 wont start

Hi all,

I am new to webMethods and have only taken a few courses. I am using the latest release and have succesfully got the broker and IS to start up (although there are a lot of error messages) after a standard install, unfortunately the MWS will not start.

I cannnot find the reason behind MWS dying as when I run it as a Windows Service I only get the following message in the event log “The Java Virtual Machine has exited with a code of 1, the service is being stopped.” – Not terribly helpful.

I tried running it through a command prompt however the MWS.bat command opens another window and the window closes almost immediately - I started debugging the batch file but this is going to take some time to work out all the paramaters and attempt to pause before it dies.

I used an External RDBMS connection to SQL Server 2005 and I think this may be cuasing the problems. Possibly some of the connection string or a password is incorrect. I am to naive to draw the conclusion that if Broker starts then so should MWS becuase they are using the same DB and credentials. Unfortunately at no stage do you actually test your connections when installing the product, this I found bizarre. You can’t even change it in a config file, apparently you have to do it through IS administration in the 7.1 version.

Anyways, does anyone know a quick way to debug the reason why my MWS does not want to start. Is there some admin tasks that I may have missed?

The log files are located in \MWS\server\default\logs.
Look at all the logs and see if that explains your problem.

Did you install the database side objects before starting the server?

Thanks sekay. I would have thought a handy place to detail this would be int the MWS documentation.

The error I get is that the schema I specified is invalid. So basically just confirms my throughts about the data connection but all in all a pretty useless error message? Can anyone interpret?

2008-02-13 11:02:55 PST (Framework : FATAL) - [POP.004.0201] Cannot initialize MWS, invalid database schema is specified
com.webmethods.portal.system.init.InitializationException: [POP.004.0201] Cannot initialize MWS, invalid database schema is specified

Glad it helped.

Now look at
\MWS\server\default\config\db.xml
for your database connection properties. Change them as necessary if they are wrong and repeat the process.

Also, make sure you created the MWS objects in the database you specified before starting the server.

By any chance, are you using SQL Server 2005 Express version?

I am using SQL Server Development or Standard. I eventually found that the table specified in the DB.xml wasn’t created and that is the cuase of the error. I deleted the database and ran the Database configurator to recreate the database and now it works.