Modify or Delete buttons produce Windows Error

X-Application Version: 4.1.1
Tamino Version : 4.1.1
Platform : Win2k
WebContainer : Tomcat 4.1.24
JDK Version : 1.3.1


X-Application and samples included are running, but, every time I generate a new application I can not modify or delete documents, because when I pass the mouse over a modify or delete button a window error appears saying:

An error has been produced in execution time. Do you want to debug it?
Line: Nr
Error: An object was expected

And Yes or No buttons

If I press Yes button, Microsoft Development Environment is opened debuging IEXPLORER, and hightlight this line:

Any idea what can be happening?

Thanks in advance,


[This message was edited by Harald Wolf on 02 Apr 2003 at 07:33.]

Hi Rosa,

thank you for your post.
I can reproduce your error, but I’m able to continue the application without logical problems.

It is ‘just’ a displaying problem. I don’t know, why your InternetExplorer stops working…
Wich version of it do you use?

The reason why this error occurs is, that a reference in the basics.xsl is missing.

As a solution just replace the file \xapplication_411\src\com\softwareag\xtools\xapplication\generator\resources\style\xsl\basics.xsl
by the attached file.

Now regenerate your application and it should work.

Bye the way, Tomcat 4.1.24 might produce problems. Please have a look at the following post:
Xapplication 411 installation successful but can’t run the examples

basics.xsl (30.4 KB)

Thank you very much, Thorsten.

I had already seen the post you tell me, and samples are working, the problem appears with new generated applications.

Yesterday night I realized the problem was related to Internet Explorer version (mine is 6.0.2800.1106). I downloaded Netscape 7.0 and it worked.

Today, after demo, I have seen your response and I have tried with the new basics.xsl, and it works even with the Internet Explorer mentioned.

Thanks again,