Microservice cep not found error when creating smart rules

Hello, I’m trying to experiment and learn, but getting error message when trying to creating smart rules:

{
  "error": "SmartRule/Error",
  "message": "Http status code: 404\n{error=\"microservice/Not Found\",message=\"Microservice cep not found.\",info=\"https://www.cumulocity.com/guides/reference-guide/#a-name-error-reporting-a-error-reporting\",details=\"null\"}"
}

Things I have tried already:
Give my user the CEP Manager role
Give my user all roles including admin (I also tried to change the admin role to have all permissions and to be subscribed to all applications including “Smartrule”)

I suspect there is some silly solution or just something to do with roles that I missed

Please help!

Hi Viktor,
please let me know the URL of your tenant then I can take a look.
Regards, Christian Herzog

attenteciot.eu-latest dot cumulocity dot com

Hi Viktor,
the microservice Apama-ctrl-starter was not subscribed to your tenant.
After the subscription you can create smart rules again.
Unfortunately I found no hints why the microservice was not subscribed, as this subscription is default for all new tenants.
Regards, Christian Herzog

Thanks for the fix Christian! How did you subscribe the apama-ctrl-starter microservice to my tenant? Are there any other microservices that are supposed to be subscribed by default, that might not be?

Hi Viktor,
with the access on the management tenant I could enable the subscription, which is not possible in the tenant itself. The management tenant can be accessed only from authorized Software AG colleagues.
Other missing subscriptions I could not see for your tenant.
Regards, Christian Herzog