Losing JDBC connections


We have conifigured JDBC Connections with the database Oracle 8i using the IntegrationServer Administrator.These connections were used by many services in the webMethods Developer.Suddenly these connections got lost in the JDBC Adapter.We dont know the reason why it is getting deleted.

We need to know the reason why it is deleted and how to solve this issue.
I suspect something is happening to the connection .
Is there any chance that the database connection might have timed out ?

we are using the Connections with these settings:
TransactionType : NO_TRANSACTION
DataSource class:oracle.jdbc.pool.OracleDataSource
Enable Connection Pooling ;True
Maximum POOl:20
Block TimeOut:30000
Expire Timeout: 30000
Startup BackOff timeout:10.
Temporarily we are solving this issue by recreating the connections.

Please help me to get rid of this issue at the earliest.


Its weird,how it will lost by itself…any server restarts in the backup times?? unless some one deletes the connections thru IS administrator console…At that time are you still seeing the adapter connections in the stored package?

I dont think connection timeouts will cause this problem.Also set minimum connections=0


Thanks to your response.
Yes,As you said,the JDBC Connection never gets deleted automatically unless someone deletes the connections.But we are sure that nobody from our side is doing this.

After taking a hard look at this problem, i found that there is no enough space in the File system of the machine on which the IS server is installed and running.
Please tell me ,whether it may cause this issue in IS JDBC connections?


As far i know yes memory loss on the OS side could crash IS and related hosted components.


Now the JDBC connection is not getting deleted as we have made the filesystem space as available to run the tasks.
Now we are facing the problem in rebooting the IntegrationServer.
If we start the server in command prompt by using the command ./server.sh in bin directory.
The server starts running for sometime and after that it goes down automatically by leaving the Exception in the prompt.
The exception is ,

at wm.broker.admin.ServerBackgroundThread.run(ServerBackgroundThread.java:74)
at wm.broker.admin.ServerBackgroundThread.run(ServerBackgroundThread.java:74)

I have checked the Broker Status also, it is running only.
I dont know ,why the server goes down automatically.
i can understand that the server is interrupted by this thread.I want to know the way to tackle this
Please help me in this.

I guess there are some problems with repository files or other.

Chech the logs in logs/server*.log for any message. I suggest clearing WmRepository2, WmRepository4, DocumentStore directories.

It is often the case, that when filesystem is full these files get corrupted.

I met the same problem this morning. All JDBC connection pool lost and no one could manually delete it.
I found it was caused by the one of our member is try to reload the package wmART on production. Package wmJDBC is depends on wmART so it is unload/reload as well.

All your JDBC connection is saved in the your designate package but it has no relationship with package wmJDBC. I guess you need to reload the package to solve the problem.

Hi Vijayalakshmi!

This was worked out for me, i have got the lost connections also. so try it once. Go to \IntegrationServer\config\backup
There edit the server.cnf file
And add watt.server.auditStore=local
Then restart the server once. If it worked out, plz let me know.