Logon to Local Natural Runtime


This is probably a typical question from a novice, but I must say I am greatly puzzled.
I read all help pages in NaturalONE about deployment, but I may have missed the principal message.

The following story is documented by screenshots in the attachment.

I started out with the HelloWorld sample application.
The project is automatically configured to use the local Natural runtime.
I specified my userid and a password in the properties dialog and saved it.
Is there a specific password required here, or is it free?

The hostname and port properties say localhost:2800.
But they are greyed out: are they valid at all, then?

The main program is called HELLO-P in library SAMP4ONE.
The project was successfully built.
It runs ok in NaturalONE -> Execute.

I proceeded to create a new wardeploy.xml file.
But I am not sure which session settings I have to specify.
Are they:

I hope the syntax is ok since I do not have much Natural experience.

I then ran the Ant build job and copied the resulting war file to the internal Tomcat’s webapps folder.
Tomcat properly unpacked it and created a HelloWorld web context.

I could the enter the URL
and it was properly expanded to

But entering my userid and password just produces the message:

Want went wrong?

By the way, my NaturalONE is 8.2.6. on a Windows PC.
Any help would be greatly appreciated.

Hubert Kauker

HelloWorld.pdf (139 KB)

You should deploy to an external server, not the internal Tomcat :wink:

Sorry, does not work.

I have my own Tomcat, too, running on port 8081.
I copied the generated war file to this Tomcat’s own webapps directory. It was automatically unpacked, ok.

Loading http://localhost:8081/HelloWorld has a response and sends a menu with options “Start Application (HTML)”,
“Start Application (SWT)” and so on.

Selecting “Start Application (HTML)” the Logon screen comes up.
I type in my userid and password, but only get the Error message:
“Connection to host localhost failed. Connection refused: no further information”.

See screenshots in the attachment.

Please, can somebody tell me, what session settings (host) are expected by the Natural War Ant Deployment wizard?
In particular: Session host name (localhost ?), Host session port (2800 ???), Session application name (HELLO-P ?), Session parameters (STACK=(LOGON SAMP4ONE) ???).

Honestly, I have read the NaturalONE docs from end to end and found no clue to these, at least not for this particular practical case.

I would be particularly interested to know: has anyone done this in practice and does it really work? Using the local Natural runtime?


HelloWorld2.pdf (83 KB)

Port 2800 is the Web I/O server, did you set one up, too, or just a Tomcat listening on port 8081 ?

I never did anything explicit so set up or configure port 2800.

I just did the standard setup of the IDE.

Have a read about the Web I/O interface then, this is what needs to be set up when you want to run an application “externally”.

Quite interesting material. Thank you.

In NaturalONE Help on page
Software AG Designer Guides > NaturalONE Help > Application Development > Using NaturalONE > Working with Natural Projects in Local Mode
we have a section named Runtime quite at the bottom, and here we read

In my project the option button is visible on the Natural/Runtime tab in the project properties dialog.
So I conclude the local Natural runtime is installed.
And as it is promised above, a host name (localhost) and a port number (2800) are provided and the corresponding text boxes do appear gray.

When I build a Natural program or subroutine, say, I can see in the Console view that a connection is made to server localhost(2800), a logon to my library is made, the object is stowed, and then a disconnection from server localhost(2800) is done. All as it should be.

So, does this not indicate that the system is ready for use with a (complete) local Natural runtime?
Where, in fact, do we learn that something like a Web I/O Interface needs to be installed on my PC in addition?

I still hope that we get it to work and that only some parameter was wrong.

Thanks again.

I hope my answer to the similar posting http://tech.forums.softwareag.com/techjforum/posts/list/51518.page helps clarifying also this issue.
Regards, Thomas