Location parameter in TN Profile Primary FTPS

Hello everyone

environment: webMethods 7.1.2

I am trying to use partner profile–>delivery methods–>primary FTPS to FTPS a file over to a partner.And our partner had our login credentials defined to home dir(i.e. we don’t have to CD to subfolders).But the ‘location’ field in ‘primary FTPS’ is indicated as mandatory.
So woundering what need to be entered for this field.I tried using \ and / but didn’t work .Also checked webM documentaion but it didn’t speak about the above scenario(only says enter remote path)

*below is the error i am getting in TN activity log
[ISC.0064.9001] Could not connect to ftp server: Connection timed out:could be due to invalid address


FYI: Also tried manual FTP(from cmd) with out CD and it worked

please advise
Anil

An add on to my above post

The same ‘location’ parameter(with required constraint) exists for PrimaryFTP as well .Do you think modifying the backend TN scripts to remove required constraint would resolve the problem?

thanks
Anil

Yes Location address is mandatory,its not adivisable to change the default configuration/backend tables.But since you are login to home directory setting “/” should work i believe.

HTH,
RMG

I’m having same problem. Did anyone solve this?
Using just / gets a 550. A space is not acceptable either.
If I run pub.client.ftp I can leave the location blank and it works perfectly so it’s only in the Preferred Protocol Primary FTP

Hello

I used . (period) i.e. current directory and it worked fine

thanks
Anil

thanks anil
However I still get the 550
Here’s the background.

Connecting to an AS/400 with an Integrated File System that simulates a pc.
When initially connecting with / it was placing the files in the system root on the remote server. I could see the enter file system on the remote server.
However when testing with pub.client.ftp I could only see my remote login dir as expected.

Client fixed policies on remote server as I should not be able to access and write to the system root.
Now / or . or /home/mydir/ does not work on primary FTP and /home/mydir/ does not work on pub.client.ftp either but . and / works for pub.client.ftp.

What’s the difference between primary ftp setup and pub.client:ftp? You would think the underlying code is the same.

“What’s the difference between primary ftp setup and pub.client:ftp? You would think the underlying code is the same”
–> Yes it could be diff code esp location…So for customization needs go with service level ftp (client.ftp services breakup login,cd,put,logout) processing instead.

But 550 sounds a permission issue …did you check with the remote server folks on the dir privileges?

http://advantage.webmethods.com/article/?id=SR-1-55512081

HTH,
RMG

Chris,

My understanding is that Built in FTP service(pub.client:FTP) is registered as ‘Primary FTP’ to TN.So they should be the same
You should have already done this but just to make sure did you check to make that same log on credentials are being used for both Primary FTP and pub.client:FTP?
In my scenario either both FTP’s i.e. primary FTP and pub.client:FTP failed or succeeded by using various location parameters like . / and home dir from root

thanks
Anil

I know that.
Was trying to avoid that and make use of the preferred protocol as that’s why it’s there.

Yup credentials are same.
I should have said this is WM 8.0.1

pub.client:ftp is not the registered service. The registered service is wm.tn.transport:primaryFtp. It uses pub.client:ftp underneath.

The TN service basically gathers the information from the profile and calls pub.client:ftp.

Check for a trailing space in one of the fields of the TN profile. Using . as the location “should” work.

Working with “.” dot.

I re-entered all the information. Must have been a typo some where.
Thanks for confirming my assumption that the underlying code is the same. Would be totally stupid if it wasn’t.

Glad to hear it worked…Thanks for the update!