Kafka Consumer Service Issue

Hi Team,

I have created a sample consumer service in webMethods Designer using “Kafka Consumer Connection”.I was able to execute Producer service and produce message into a topic.But,while executing consumer service by providing topic name as input,the following error is encountered.Could anyone help me out in finding solution for this issue.
Please refer the screenshot attached for error details.

Thanks,
Sindhura.

Hi Sindhura,

Kafka adapter only supports the following Kafka server version.
Apache Kafka 0.9.0.x
Apache Kafka 0.10.x.x
Apache Kafka 0.11.x.x
Apache Kafka 1.x.x.x

So make sure you’ve taken the client libraries(*.jar) from your Kafka server that runs on these versions.

AFAIK, your error was due to Caused by: java.lang.NoSuchMethodError: org.apache.kafka.clients.consumer.KafkaConsumer.assign. I suspect you’re using kafka-clients.jar file that the version is not supported.

Hi,

I took the client libraries(*.jar) from installed Kafka server with proper version.Still I’m facing the same issue.

Thanks.

May I know the Kafka server and Zookeeper version? I had done some POC around this using the OOTB Kafka adapter and share you the configs if it matches with my versions.

Hi Mahesh,

These are the versions I have used for Kafka Server.
kafka_2.11-0.10.0.0
zookeeper-3.4.14

Thanks.

Hi Sindhura,

This setup is not officially supported by SAG and according to ASR, SAG supports up to kafka 1.x only(the recent one for v1.x is Kafka 1.1.1). There is no guarantee from SAG if customer runs on the versions not officially certified yet by SAG.
kafka_2.11-0.10.0.0(Released Nov 20, 2018)
zookeeper-3.4.14

https://kafka.apache.org/downloads

I can confirmed that Kafka adapter works fine if running on the support versions, as I’ve previously reproduced customer defect issues before on local Kafka server I’ve setup. Also a good practice is to apply the latest Kakfa Adapter fix available. I remembered back then in May 2019, the latest fix level was KAF_9.6_Fix3.

Hi

I have tried with the below two versions also,still facing the same issue with kafka consumer service.

kafka_2.12-2.3.0
kafka_2.11-1.1.1

Could anyone suggest which version does SAG supports exactly.

Thanks.

These are the version on which I had done the POC using IS 10.3 and I was able to connect, produce and consume messages to Topic.

kafka_2.11-2.1.0
zookeeper-3.4.12

I would suggest you to open an SR with Software AG.

Hi Mahesh,

Thank You! I have tried with the version(kafka_2.11-2.1.0,zookeeper-3.4.12) you have shared, still unable to execute the consumer service for Kafka. Please help me in resolving this issue.

Thanks.