JRE upgrade

We are using IS 6.5 and JRE 1.4.2_07(given along with IS6.5).Now we have a requirement to upgrade the JRE to 1.4.2_11 or later.My question is after the JRE upgrade, do we need to recompoile all the Java services developed in that IS and please also let me know things I need to consider for this upgrade.

Thanks,
Kash.

You don’t need to recompile anything. You may however run into some security issues. Read this thread to find out more … http://wmusers.com/forum/showthread.php?p=46717#post46717

I assume the desire to move _11 is for the timezone changes. You can address that by updating the time zone data for _07. http://java.sun.com/developer/technicalArticles/Intl/USDST/ has more info. Get the “tzupdater” tool from the Java SE download page. Using the tool can help avoid the issues introduced after _07.