Java Source not available

When i trying to create or trying to open existed java service, i am unable to see the source code. It is showing like below image.

Already existed java services were created by me only. How can make visible the source code.



java.frag files are missing in ns directory under the package on your file system. Can you have a look at that.

Are these java services are coded by you or it is provided by SAG (Eg. WmPublic)

These java services are coded by me only. And java.frag files are not missing.

Strange :slight_smile:

Do you have .java file under /code/source/

Yes, i have .java file under code/source

Really strange. For now I can only suggest these options:

1> Reload the package
2> Copy paste the java service in a different folder under different package, save and compile.
3> Check if the shared tab is showing something.
4> Try to run java service with required inputs and see whether you are getting required output.
5> Last option is to recreate your java service from .java file :slight_smile:

on the service under the package navigation tree, right click: Properties
check permission settings. make sure you have write permission

1 Like

Thanks Tong. Worth trying what he suggested.

I am still using developer. Not used to designer yet :!:

Akash WM,

Even I faced the same issue on wM 8.2 designer “java service (user created) source not available (the issue is intermittent)”. Even I tried changing the permission on properties, reload, refresh etc but it did not work for me.

Workaround: Copy paste the java service in a different folder name under same package, save and unlock the java service. Later on you can rename the folder that you created in the first step.

Let me know if you have any other fix/workaround for this.

Time to time I have same problem with 9.0, I’m using Java Perspective to refresh the package/project in worst case restarting designer…

Martin - Did you try the above workaround?

if java service is working in one environment and not working in other environment , check the node.idf file.